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Learning resources 
The following material will help you learn and use PlanogramBuilder. 

List of Learning Material 

User guide 
This user guide is your main reference material for learning how to use PlanogramBuilder. It is 
accessible by clicking on the Help button in PlanogramBuilder. 

Its sections are organized in a way that should match the chronological learning process. We 

therefore advise you to browse it in the order the chapters are presented. 

It also contains many step-by-step instructions with illustrations and screen captures to show 
you how to perform typical tasks. 

The user guide does include topics on all features available in the application so it is our most 

complete source of information. 

If you have trouble finding a topic in the tree menu on the left pane (Contents), you can also 
search Topics in a listing (Topics) or by text search (Search). 

Each section can also be printed out individually should you want to keep a paper reference for 

more complex features. Use the link labeled Print current topic on the upper right corner of 
this page.  

A PDF version with the exact same content is also available from the link in the top right 

corner of this page: User guide in PDF format. 

Tutorials 
This user guide includes a few tutorials with sample files when necessary for the more complex 
tasks. You will come across them when you consult one of these advanced topics. 

There are also video tutorials on PlanogramBuilder YouTube channel: 

https://www.youtube.com/user/zVisuel. These video tutorials can also be opened directly from 
within the application by clicking on the Tutorials button. 

Tooltips 
Many tools and command names in PlanogramBuilder are quite self-explanatory. Additionally 

hovering your mouse over any button displays a tooltip with a quick textual description. 

FAQ 
Some often asked general questions are listed in our FAQ: 
https://planogrambuilder.com/faq.html 

User assistance 

If you are stuck with using some feature or have a question, we will gladly assist you. Please 
see the dedicated section of this user guide: Assistance. 

https://www.youtube.com/user/zVisuel
https://planogrambuilder.com/faq.html
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PlanogramBuilder Introduction 
PlanogramBuilder is an application to create planograms. Planograms help you plan, optimize 
and communicate the placement of your products in retail stores. 

PlanogramBuilder is a web-based application running on Windows PCs. Your company can have 

any number of users accessing PlanogramBuilder from anywhere with a web-capable PC.  

This system is very flexible as it can suit small companies with a single person doing 
planograms or very large companies with 500 persons doing planograms across the world. 

The PlanogramBuilder solution is designed for an easy and seamless deployment with a ready-

to-use centralized database that can carry all your product line. This means that all of your 
users will have access to the same set of products.  

The database is hosted on our servers, so you don’t need any database knowledge to use 

PlanogramBuilder.  

Typically, one or a few designated power user(s) in your company (PlanogramBuilder 

Administrator) manage(s) the product database. The other users (Standard Users) are able to 
create, edit and publish planograms. See all the difference between user roles in Choosing 

User Roles. 

When a PlanogramBuilder Administrator adds a product to your PlanogramBuilder database, 
this product instantly becomes available to each user of your company for planogramming. 

 

     Schematic representation of the PlanogramBuilder solution 

PlanogramBuilder includes many features to let you create beautiful planograms quickly, to 
analyze potential returns and to export reports and images of your planograms. The summary 

list of features is available on our web site at https://planogrambuilder.com, and a video tour 
at https://planogrambuilder.com/planogrambuilder-video-presentation.html. 

In this user guide, we will explain in detail all features and tools available in the application. 
You will also find many tips and shortcuts to be more efficient with PlanogramBuilder. 

https://planogrambuilder.com/
https://planogrambuilder.com/planogrambuilder-video-presentation.html
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Installation and Startup 
This section explains how to install, launch and set main parameters of PlanogramBuilder. 

System Requirements 

Microsoft Windows 
 

Operating System: Microsoft ® Windows™ Vista, 7, 8, 8.1, 10, 11 

64-bit Windows™ version required 

CPU: Intel or AMD 64-bit processor (CPU) (recent multi-core CPU advised for 
best performance) 

Display 1280 x 720 resolution and above (1920 x 1080 or higher advised) 

Mac OS × or other operating systems 
You can run PlanogramBuilder on a Mac, Linux or Solaris computer by installing Windows™ 
XP, Vista or 7 on these systems. If you already have access to Windows from your Apple, Linux 
or Solaris computer, you can directly install and run PlanogramBuilder. 

If you don’t have Windows on your computer, our recommended solution is to install Windows 
and PlanogramBuilder inside your OS environment so you can run PlanogramBuilder directly 
from your preferred OS. There are several software solutions to achieve this: 

• Oracle VirtualBox (https://www.virtualbox.org/): for Mac OS X, Linux and Solaris. Free 

license. 

• VMware Player (https://www.vmware.com/products/player/): for Linux. Free license. 

• VMware Fusion (https://www.vmware.com/products/fusion/): for Mac OS X. 

• Parallels Desktop (https://www.parallels.com/products/desktop/): for Mac OS X. 

Another solution to run PlanogramBuilder on a non-Windows computer is to install Windows as 
an alternative OS with dual-boot. This method will however require you to restart your 
computer every time you want to switch between your OS and Windows/PlanogramBuilder. For 

a Mac, please see instructions at https://www.apple.com/support/bootcamp/. 

Note: the system requirements are the same as listed for Microsoft Windows. 

Install PlanogramBuilder 
Check what’s new in the latest release at https://planogrambuilder.com/newsletters/2022-
06/2022-06-PlanogramBuilder-newsletter.html. 

 

To install PlanogramBuilder latest version, choose one of the installation methods: 

• Normal installation: This is the suggested and standard method for most users. 

• Unattended installation: This method can be used by IT staff to install PlanogramBuilder 
remotely. 

https://www.virtualbox.org/
https://www.vmware.com/products/player/
https://www.vmware.com/products/fusion/
https://www.parallels.com/products/desktop/
https://www.apple.com/support/bootcamp/
https://planogrambuilder.com/newsletters/2022-06/2022-06-PlanogramBuilder-newsletter.html
https://planogrambuilder.com/newsletters/2022-06/2022-06-PlanogramBuilder-newsletter.html
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Normal installation 

Video tutorial on this topic: 1: Installing PlanogramBuilder 

 

1. Close PlanogramBuilder if you already have a version opened. If you are updating 
PlanogramBuilder, you don’t need to uninstall the old version: simply follow the next 

steps; you will also retain all your data.  

2. Download the installer: click on the following link or paste the link in your web 
browser address field: 
https://planogrambuilder.zvisuel.com/downloads/PlanogramBuilderSetup.exe 

3. Run the installer after it has been downloaded. 

 

Note: the installer requires Administrator privileges, so if you are prompted to enter an 

administrator password, please ask your IT. 

 

https://www.youtube.com/watch?v=VFezvXKeJw4
https://planogrambuilder.zvisuel.com/downloads/PlanogramBuilderSetup.exe
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4. Follow the on-screen instructions until installation has completed. 

Unattended installation 
This installation method is convenient for IT managers who must install PlanogramBuilder onto 
remote computers. 

1. Close PlanogramBuilder if you already have a version opened. If you are updating 

PlanogramBuilder, you don’t need to uninstall the old version: simply follow the next 
steps; you will also retain all your data.  

2. Download the installer and save it to your hard drive: click on the following link or 
paste the link in your web browser address field: 

https://planogrambuilder.zvisuel.com/downloads/PlanogramBuilderSetup.exe 

3. Run the installer with the /S (case sensitive) argument. A typical call from your 
installation package/batch will be: PlanogramBuilderSetup.exe /S 

4. Optionally, use the AccountID command line parameter for the installer. This lets you 
enter your account ID at installation, so the users won’t need to enter the account ID 
when they run PlanogramBuilder. 

Example: PlanogramBuilderSetup.exe /AccountID=goodcompany_ihrpz437 /S 

Note: The AccountID parameter name is case insensitive 

Note: if the target session has no administrator rights, the main installer will have to escalate 
the privilege to admin before this call to avoid the dialog asking for admin credentials. 

Update PlanogramBuilder 
PlanogramBuilder is updated on a regular basis to bring improvements. Check what’s new in 
the latest release at https://planogrambuilder.com/newsletters/2022-06/2022-06-

PlanogramBuilder-newsletter.html. 

You will be notified on screen at each required update and guided to perform the installation. 

https://planogrambuilder.zvisuel.com/downloads/PlanogramBuilderSetup.exe
https://planogrambuilder.com/newsletters/2022-06/2022-06-PlanogramBuilder-newsletter.html
https://planogrambuilder.com/newsletters/2022-06/2022-06-PlanogramBuilder-newsletter.html
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Launch the application 
Once installation is complete, you can run PlanogramBuilder: 

1. Click on the PlanogramBuilder icon on your Desktop or in your Windows Start Menu 
(All programs (or All Apps) > PlanogramBuilder) 

    

2. Enter your account ID, user name and password as provided to you by email after 

purchase or registration. Note: if you are still using the web version and haven’t 
received an email message showing your Account ID, you can find your Account ID on 
your PlanogramBuilder Web application login page. 
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3. Click on Login. 

Note: You still need to be connected to Internet when using PlanogramBuilder since the 
database is online and most functions work with dynamic aspx web content. 

Note: By default, your login credentials are automatically remembered for subsequent use of 
PlanogramBuilder. If you prefer to enter your login information each time you launch the 
application, please see Startup Settings.  

Startup Settings 
Video tutorial on this topic: 3: Startup settings 

Display login screen 

If checked, forces PlanogramBuilder to always show the login screen. If unchecked, the login 

screen is bypassed when Save user & password is checked. 

1. Click on Settings  

 

2. In Settings affecting the current user only, under Login, change the following 
parameter: 

 

Save user and password 

If checked, the application will remember the last entered user name and password so you 
don’t have to type them again. 

1. Click on Settings  

 

2. In Settings affecting the current user only, under Login, change the following 
parameter: 

 

https://www.youtube.com/watch?v=PdwYV2zj7dA


PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       10

 

Command line parameters 

There are a few parameters you can add to the PlanogramBuilder shortcut or command to 
modify the way PlanogramBuilder runs. 

Video tutorial on this topic: 3: Startup settings 

AccountID 

This parameter lets you predefine an account ID to use when launching PlanogramBuilder. This 
option is useful mostly if you use several distinct PlanogramBuilder account IDs. You can 
create several copies of PlanogramBuilder shortcut and assign a different account ID to each 

shortcut, so you will be able to launch directly with the desired account. 

Value: any account ID can be used as value for this parameter. 

Format: /AccountID=value 

Example: PlanogramBuilder.exe /accountID=goodcompany_ihrpz437 

Note: The AccountID parameter name is not case sensitive. 

 

To enter or edit the parameter, do as follows: 

1. Right-click on the PlanogramBuilder shortcut. 

2. In the context menu, click Properties. 

3. In Properties > Shortcut > Target, type the parameter after the application path. 

https://www.youtube.com/watch?v=PdwYV2zj7dA
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4. Click OK to save your changes. 

5. Now click on the shortcut icon to start PlanogramBuilder using your parameter. 

 

User Roles 
PlanogramBuilder provides two possible user roles for each user, each role with different 
permission levels: 

• PlanogramBuilder Administrator 

• Standard User 

Typically, only one or a few managing user(s) in your company is (are) PlanogramBuilder 

Administrator(s).  The other users are only able to create, edit and publish planograms.  

If your company has only 1 user, the user is automatically a PlanogramBuilder Administrator. 

If you have more than 1 user, you can choose which user(s) should be PlanogramBuilder 

Administrator(s), and which should be Standard User(s). 

When you order your PlanogramBuilder user licenses, you will be asked by email which user 

role to assign per user. You can also write at any time to planogrambuilder@zvisuel.com to 
request changing the role of one or more users. 

List of User Roles 

mailto:planogrambuilder@zvisuel.com
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Please find below a description of each user role: 

PlanogramBuilder Administrator 
PlanogramBuilder Administrators have access to all features of the application. 

Here is the list of features available only to PlanogramBuilder Administrators: 

Customizing and Editing the Product Database: 

• Database Setup 

• Clear Database 

• Add Database Item 

• Modify Database Item 

• Delete Database Item 

• Batch Import Database Items 

Advanced Planogram Project Management: 

• Template Projects 

• Share All Projects 

• Backup and Restore Projects 

Set other preferences affecting all users in your account Id: 

• Locked Bays for Standard Users 

• Application Title 

• Application Logo 

So for example, when a PlanogramBuilder Administrator adds a product to your 
PlanogramBuilder database, this product instantly becomes available to each user of your 
company for planogramming. When a PlanogramBuilder Administrator changes the logo of 
your company in PlanogramBuilder, it applies to all other users. 

Standard User 
Standard Users can run PlanogramBuilder, set individual user preferences, use the product 
database content, create, save and publish planograms. 

So typically you will assign Standard User role to users who don’t manage the product 

database and don’t need to manage the planogram projects created by other users. 

Main Settings 
Video tutorial on this topic: 2: Main settings 

 

Discover how to set PlanogramBuilder to match your language, measurement unit and other 
preferences. 

  

• Settings under Settings affecting the current user only apply only to the current 

logged-in user. These settings are available to each user. 

https://www.youtube.com/watch?v=r6GbNQczkZs
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• Settings under Settings affecting all users apply to all users in your account ID. 

These settings are only available to PlanogramBuilder Administrators. 

 

GUI Language 
The PlanogramBuilder Language lets you change the language for all the elements of the user 

interface, such as commands and buttons. 

1. Click on Settings. 

 

2. In Settings affecting the current user only, below Regional Settings, next to 
Language, select your preferred language from the list. 

 

Note: Currently, German, English, Spanish, French, Hungarian, Portuguese, Bulgarian 

and Russian are available. If you wish to have the interface translated to another language, 
contact us at planogrambuilder@zvisuel.com 

Note about this User Guide language: The PlanogramBuilder documentation is published 
online in English only, however if you set the user interface to a different language, this user 

guide will be automatically displayed in that language using Google translation for your 
convenience. Beware that the names of commands and other interface elements may differ in 
the automated translation from those in the user interface. In case of doubt always consider 
the names displayed in the user interface as references.  

Measurement unit 
Each user can select in which Measurement unit dimensions are displayed for products and 
shelving items. You can choose mm, cm or inch. The inch unit is displayed in decimal inches. 
The default unit is cm. 

1. Click on Settings.  

 

2. In Settings affecting the current user only, Below Regional Settings, next to 
Measurement unit, click on the radio button corresponding to your preferred 
measurement unit. 

 

Note to PlanogramBuilder Administrators: 

The selected Measurement unit is also used when you create, edit or export products with 

Database Editor (see Database Item Properties: width, depth and height). 

mailto:planogrambuilder@zvisuel.com
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The selected Measurement unit will also be used by default to batch import products, but you 

can override the selected unit. Please see Batch Import Database Items for further 
explanations.  

Application Title 
Note: Only available to a PlanogramBuilder Administrator 

The Application Title lets you specify a title for all PlanogramBuilder users in your company. 
Normally, the title already shows your company name or your name if you are an individual. 
The title appears in light blue at the upper right corner of PlanogramBuilder screen: 

 

To set the title: 

1. Click on Settings.  

 

2. Under Settings affecting all users, next to Application Title, type in the name of 
your Company or the title of your choice. 

 

Application Logo 
Note: Only available to a PlanogramBuilder Administrator 

The Application Logo displays an image on the title bar visible to all PlanogramBuilder users 
in your company. Typically you can display your own company logo: 

 

To upload the logo: 

1. Click on Settings. 

 

2. Under Settings affecting all users, next to Application Logo, click on Browse. 

 

3. Select an image file on your computer. 

4. Accepted formats are JPG, GIF and PNG. 

5. Images with a transparent background are supported in PNG format. When such image 

is used, the normal PlanogramBuilder title bar is displayed behind the transparent part 
of the logo image. 

6. The image must have a fixed height of 41 pixels and a maximum width of 200 pixels. 
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User Interface Scaling 

The scale of PlanogramBuilder user interface elements is controlled by your Windows display 
scale settings. Specifically: 

Interface Overall Scaling 

You can increase the scale of elements for all Windows applications including PlanogramBuilder 
as follows: 

1. Close PlanogramBuilder. 

2. Open Windows Settings > Display. 

3. If you have multiple displays, click on the desired display. 

4. Under Scale and layout > Change the size of text, apps and other items to the desired 
scale. 

5. Restart PlanogramBuilder. The application interface is now scaled as per your choice. 

 

Note: If the texts in PlanogramBuilder become blurry, check our troubleshooting in Blurry text 
in the GUI. 

Interface Text Scaling 

You can increase just the size of text elements for all Windows applications including 
PlanogramBuilder as follows: 

1. Close PlanogramBuilder. 

2. Open Windows Settings > Ease of Access > Display. 

3. Under make text bigger > Drag the slider until the sample text is easy to read, then 

click Apply. 

4. Restart PlanogramBuilder. The application interface text is now scaled as per your 
choice. 

 

5 Minutes Tour 
This is a quick introduction to get started with PlanogramBuilder.  

Screen Layout 
Here is an overview of the PlanogramBuilder user interface: 
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The work screen is divided in two main areas: the current task panel on the left and the 
viewing area (where you see the planogram being built) on the right. The content of the left 
pane is dependent on the current task that you select by clicking on its tab. 

There are also several buttons at the top and bottom of the work screen. The ones in the 

upper left area are typically used to save and load whole projects whereas the ones in the 
lower area let you modify the current project or change the way you look at it. 

Most tools and commands are also available in the menu bar and in the context menu.  
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Place Your First Product 

 

Note: A set of sample products and accessories is provided with PlanogramBuilder. This lets 
you test the application without having to add your own products. Database (Products, 
Accessories) chapter explains how to delete these products and add your own. 

1. After logging-in, make sure the Create Bay task is selected, then click on the Add 
button to create a new bay. (You will learn later how to specify your own parameters 
for new bays in Create Bay.) 

 

2. After the bay has appeared, click on the Products Tab. 

3. Click on Confectionery under Category. 

4. Drag & drop products from the library to shelves in the visual area. 
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5. That’s it. You can now try to add more products and re-arrange them on the shelves. 
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Database (Products, Accessories) 
 

Video tutorial on this topic: 4: Introduction to the database 

 

PlanogramBuilder stores all your Products and Accessories (accessories) in an online database 
that is automatically created and hosted on our application servers. As a PlanogramBuilder 
customer, you don’t have to install or set up any database, but you need to add your own 
products to your database. 

Each PlanogramBuilder customer has a distinct database so you won’t risk sharing any 
confidential information with other customers. Each customer can have an unlimited number of 
registered users all accessing the same customer database. This system keeps your product 
assortment always up to date for each PlanogramBuilder user. 

When you launch PlanogramBuilder, the program connects to your database and looks for the 
items in the database. All the items found in your database appear in the Product Catalog or 
Accessory Catalog, ready to drag and drop into your planograms projects. 

In order to manage the Item List in your database, PlanogramBuilder provides a set of 
features, most of them accessible from the Database task. 

Important Note: Standard users cannot edit the database. They have to contact a 

PlanogramBuilder Administrator to request changes in the database. 

Database Editor 

 

Video tutorial on this topic: 4: Introduction to the database 

Database Editor provides you with the tools to view, add, edit and delete products 

and accessories in your database. 

To launch the Database Editor, click on the Database tab. 

https://www.youtube.com/watch?v=RhqTzn8pxCM
https://www.youtube.com/watch?v=RhqTzn8pxCM
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View Database Items 

Note: If you have read-only access to the database (as a Standard User), the following 
database commands are hidden: Import, Clear and New Item. Also, the item details are 
read-only. 

Type of items to manage  

 

Radio buttons let you choose if you want to work on Products or Accessories: 

• Products are typically all sellable items. 

• Accessories are typically props displayed on shelves to enhance product presentation: 
shelf strips, labels, headers, posters, products on display out of box, etc.  

 

Click on the radio button of your choice to select the type of item you want to display. For 
example, when Products is selected, you won’t see Accessories. You can switch from one type 

to another at any time. 

Item List 

 

The left side of the screen shows a list of all your items in a table similar to a spreadsheet. 
Each line contains one item and each column corresponds to the following properties: 

Reference, Name and classification columns (A:, B: and C:), which are detailed in Database 
Item Reference. 

This is where you can view and select items in the database. 

To select an item, click on its line in the list. 

Use the Up/Down arrow keys to switch to the previous/next item. 
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A maximum of 50 items is shown on each page. If there are more than 50 items, they are 

displayed on additional pages. To select another page to display, use the page navigation tools 
in the lower left corner of the panel: 

 

• Display a page by clicking on one of the 10 visible page numbers. 

• Display the previous/next page by clicking on the left/right arrow (shortcut key: Left/ 

Right Arrow). 

• Display the previous/next page set by clicking on the left/right 3 dots. 

Note: If your screen is small, scroll down to see more items.  

Tip: By clicking on the headers at the top of each column, you can sort the list according to the 
column content. For example to order the list by product names click on the Name header and 

to order it by references click on Reference. Clicking again on a header reverses the order. 

Item Filters 

 

By default, the Database Editor shows the complete Item List in its listing. If you have many 

items in your database, you can use one or several filters to display only items matching the 
chosen filter(s). 

Filters are available for the Reference, Name and classification columns (A:, B: and C:).  

After you select or type values for filtering, the other drop-down lists only display items 

matching that filter combination, so you can narrow down quickly on available items. 

Selecting the * symbol means all available items will be displayed in the list. 

 

For the Reference and Name filters, you can type any text string: only items with values 

matching your string will be displayed. The filter boxes accept single or multiple keywords 
following these rules: 

• Multiple keywords must be separated by spaces 

• All keywords must be present 

• Keywords are not case sensitive 

• The order of keywords doesn’t matter  

Example: typing frozen CHOCOLATE in the box above Name will display all the items 

containing chocolate AND frozen in their name.  

Note: Items with values of different text cases are grouped in the Database Editor. Ex: Lego 
and LEGO are grouped as the same value. 

Item Details 

 

The right side of the screen shows all the properties of the selected item. This is where you can 
review and edit each item attributes, such as name, dimensions, shape, image(s), etc. 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       22

 

Item Preview 

 

When you select an item in the list, this area displays a small preview of the item. 

Note: you can Zoom, Pan the item in the preview, and also see it in Fullscreen using the 
standard navigation tools on the right side of the bottom toolbar. 

Database Setup 

 

Note: Only available to a PlanogramBuilder Administrator 

Video tutorial on this topic: 4: Introduction to the database 

 

In this section, you will learn how to customize your database structure to match your product 
classification structure.  

Important Note: Please perform this step prior to start filling your database with 

products, because your customization will have an impact on all future Database 

Editor Tools. 

Item Classification Properties 

 

PlanogramBuilder provides 3 properties (A:, B: and C:) to classify your products and 
accessories as you do in your business. By default, these properties are respectively labeled 
Category, Brand and Product Line. You can change these labels to match your own 
classification criteria. 

 

To customize these properties, do the following: 

1. Click on Settings.  

 

2. Under Settings affecting all users, Item Classification Properties, select a label 
from the drop-down list for each property (A:, B: and C:). 

https://www.youtube.com/watch?v=RhqTzn8pxCM
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The above image reflect example 3 on table below 

Standard labels: Brand, Brandline, Category, Group, Main Group, Manufacturer, Product Line, 

Region, Sub-brand, Subcategory, Subgroup. 

Custom labels: If the standard labels don’t fit your needs, you can also select Custom in the 
drop-down list. In this case a new text field will appear where you can type a custom label, 
such as shown below with the labels Year and Country. 

For example, you may choose one of the following combinations of classification criteria: 

 Default label  Example 1  Example 2  Example 3 

Classification property A: Category  Category  Category  Country 

Classification property B: Brand  Subcategory  Group  Category 

Classification property C: Product Line  Region  Year  Subcategory 

3. Your choices will be reflected in Database Editor header labels, as well as in Product 

Catalog, Accessory Catalog and reports. 

Item Custom Properties 

 

PlanogramBuilder also provides up to 6 additional user-defined properties for items to let you 
optionally add attributes for each product or accessory. To activate a custom property, you 

must enter its label. Once labeled, the property becomes available in your database and you 
can then assign any text value for each item in your database. You can then output the values 
of these properties in your published reports for example.  

As an example, let’s create a property to hold the weight of your products in your database: 

1. Click on Settings.  

 

2. Under Settings affecting all users, Item Custom Properties, type in the label of 
Custom property 1: Weight, then press enter to validate. 
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3. The Weight custom property is now defined and Weight values can be assigned to your 
products and accessories. The custom property can also reflected within several 
PlanogramBuilder features: 

• Database Editor detailed view 

• Project Item List 

• Report lists 

• Schematic view labels 

• Products / Accessories catalog captions and search 

Note: Custom properties which you have not labeled are not available for your products and 
accessories. 

Note: Unicode characters can be used for the labels of Item Custom Properties. 

Export Database 

 

Video tutorial on this topic: 8: Exporting the database 

 

You can export your database (products, accessories) as a spreadsheet and also include your 
item image files in the export. 

Exporting your database serves the following main purposes: 

• Create a full backup of your database. We strongly advise doing regular backups so you 
can recover your database in case you have accidentally cleared it or deleted items. 

• Create a template file in the correct format and Batch Import Database Items from a 

spreadsheet. We strongly advise performing this step before your first batch import. 

• Create a spreadsheet with your current database items to resynchronize in your 
spreadsheet editor any database changes made within Database Editor. 

There are two commands to export your database:  

 

Export L exports the list of all your products and accessories including their properties, from 
your PlanogramBuilder Database to your computer. Use this command to create a template file 
for batch importing items, or to resynchronize items when you don’t need to backup the item 
images. 

https://www.youtube.com/watch?v=3zC7RYf6JTU
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Export L+I does the same and also exports all images stored in the database. Use this 

command to create a full backup of your database, or to resynchronize items when you need 
to also backup the item images. 

 

The exported item list can be either in Microsoft Excel format (*.xls or *.xlsx), or in Unicode 

Text format (*.txt), compatible with any Spreadsheet application. 

The exported images are in the same format as they were originally uploaded. 

Follow these steps to export your product database: 

1. In Database Editor, click on the Export L or Export L+I button. 

2. You will be prompted to select a folder in which to save the files and to type a filename 
for the list of products. We strongly advise to select an empty folder or to create a new 
folder, so that your exported files won’t get mixed-up with other existing files on your 

computer. 

3. Once you have selected a folder, chosen the file type and typed a filename, click on the 
Save button. 

4. Wait for all the files to be downloaded onto your computer. The first file to be exported 

is the listing of items, which is very fast to download, then the images if you chose 
Export L+I. 

Tip: you can abort the export process by simply clicking on the Export button once again 

during the export process. 

Tip: We advise choosing the *.xls or *.xlsx format. Otherwise if you select the *.txt format, a 
number sign [#] is automatically added in the exported txt file as a prefix to all item 
References that start with a [0] or that are large numbers (more than 11 digits). This 

convention is a work-around to display these numbers correctly if you open the exported list in 
Excel, which doesn’t support long numbers. 

Note: The images are saved in a new folder named Images (or an equivalent translation if 
PlanogramBuilder is set to another language than English). Images can take a long time to 

export depending on the number of images, their size and the speed of your Internet 
connection. 

Note: The dimensions of your items (width, depth and height) are exported in the current 

active measurement unit. Please see Measurement unit for details on setting this preference. 

Clear Database 

 

Note: Only available to a PlanogramBuilder Administrator 

This command lets you reset your entire PlanogramBuilder Database to an empty state. To 
delete all items from the database: 

1. Click on the Clear button on the bottom toolbar. 

2. Then confirm by clicking OK. This will remove all products and accessories and your 
database will then be completely empty. 
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Caution: All products and all accessories will be permanently deleted from the 

database and cannot be recovered after this operation. Make sure to at least back-up 
your database before Clearing Database. See Export Database for instructions to back-up. 

Tip: If you have recently started using PlanogramBuilder and you have finished testing the 

application with the sample products provided by zVisuel, we advise you to Clear the database 
before inserting your own products in the database. This will avoid mixing up the sample 
products with your own products. You can also delete the sample project named sample 

planogram provided with PlanogramBuilder. 

Add Database Item 

 

Note: Only available to a PlanogramBuilder Administrator 

Video tutorial on this topic: 5: Adding your first product to the database 

Video tutorial on this topic: 7: Adding accessories to the database 

 

In this section we explain how to add products and accessories to the PlanogramBuilder 
database so you can then create planograms with your own items. 

Tip: The process described in this section is for adding one item at a time. You can also use 
Batch Import Database Items to add several items quickly.  

Tip: We advise backing up and then Clear Database to save and remove the sample items 
provided with the application before adding your own items. 

Instructions: 

1. Select the type of items to add: Products or Accessories. 

2. Click on the New Item button. 

 

3. In the Item Details on the right of your screen, fill-in the Database Item Properties to 
define your new item. Please consult the Database Item Reference for the detailed 
description of each property. 

 

https://www.youtube.com/watch?v=C_Sew4i9RbM
https://www.youtube.com/watch?v=g1EX8bsfnGU
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4. New Item Details for product 

 

5. Create / Cancel: Once you have entered all the desired values, press the Create 
button to validate the creation of your new item. (You can also press the Enter key on 
your keyboard.) Your new item will be created and becomes selected in the Item List. 
Otherwise, if you have changed your mind and don't want to create the new item, you 

can press the Cancel button (or the Escape key). 

 

Note: Properties in Item Details are divided into 2 groups: 

• Values set in DB only: the values for these properties can only be set in the 

database. 

• DB values that can be modified in planograms: the values for these properties can 
be predefined in the database, but you can additionally set or override these values per 

item in any planogram project. For example, you can change a product that was 
defined as Pegged in the DB to Stackable only in a particular planogram for a special 
case. 
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Tip: If you have activated one or more filter(s), the values used by the filter(s) will be 

automatically pre-filled in the corresponding text field. (See Item Filters.) You can however 
overwrite the pre-filled values by typing any other text. 

 

Notes For the fields A, B and C (the default labels are Category, Brand and Product Line):  

• Please see Item Classification Properties before entering any value. 

• If you leave a value empty in one or more of these fields, your item will be classified as 
(undefined) in the Catalog for this classification level. For example, if you don’t enter a 

Brand value for your new product, the product will be displayed in the catalog when you 
click on the (undefined) Brand. 

• Items with same text values but different cases are grouped in the Database Editor and 

Item catalogs. Ex: Lego and LEGO are grouped as the same value. 

Note: For the fields 1 to 6, please see Item Custom Properties before entering any value.  

Note: With Image, you can apply an image onto your item. Click on the Browse... button, 
browse for your image file, and then click the Open button. See Guidelines for Images for 

preparing images.  

Note: See Database Item Properties for details on what the Color is. Color can be entered in 
three different ways: 

• Click on the colored rectangle to display the color palette and select the desired color. 

• Click on the color picker icon to pick any color from the 3D item preview area. While 
pressing your mouse button over any area with the color picker, the colored rectangle 
swatch is updated with the selected color. Release your mouse button to apply the 

color. Note: the color picker mode remains active until you click on another tool such as 
Orbit. 

• Type the color value using standard HTML color codes (ex: #FF0000 for red). 

Note: We do not provide a database of products with PlanogramBuilder. Typically each client 

provides or enters directly the information about their products: name, EAN, dimensions, etc. 
and the image(s) for each product. If you don't have such data available, you may be able to 
obtain them from the product manufacturer or from third-party product databases, such as the 

ones listed below: 

• https://www.ean-search.org/ 

• https://www.upcdatabase.com/ 

• https://www.gs1.org/services/gdsn 

• https://www.mynetfair.com/ 

• https://www.grocery.com/open-grocery-database-project 

• https://openfoodfacts.org/ 

Edit Database Item 

 

Note: Only available to a PlanogramBuilder Administrator 

Tip: The process described in this section is for modifying one item at a time. Another feature, 

Batch Import Database Items, lets you to update batches of items and is much quicker when 
you need to modify several items in one shot.  

1. Select the type of items to edit with the radio button: Products or Accessories. 

https://www.ean-search.org/
https://www.upcdatabase.com/
https://www.gs1.org/services/gdsn
https://www.mynetfair.com/
https://www.grocery.com/open-grocery-database-project
https://openfoodfacts.org/
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2. Find the item you want to modify in the list. 

Note: You may have to scroll down to access the bottom of the list if there are many items. If 
you have more than 200 items listed, the list will split into several pages. Click on the page 
numbers below the list to access other pages. 

Tip: Use the Item Filters to reduce the number of items displayed and find your item faster. 

3. In the Item Details area, enter the desired values in the available property fields. Please 
refer to the section Add Database Item as the process is almost the same. The only 
difference is that you cannot edit the Reference value of an existing item. 

4. Press the Update (Enter key) or Cancel (Esc key) button to validate or cancel changes. 

5. After pressing Update, the item will be re-generated. This may take some time if you 
are uploading an image. 

6. You will see your updated item in the preview area. 

Delete Database Item 

 

Note: Only available to a PlanogramBuilder Administrator 

1. In the items list, find and select the item you want to remove from the database. 

2. In the Item Details area, press the Delete button. The item will be removed from the 
database and from the catalog (Products / Accessories tasks). 

Note: Use great caution with the Delete function, as it will permanently delete the item for all 
users in your company. 

Batch Import Database Items 

 

Note: Only available to a PlanogramBuilder Administrator 

Video tutorial on this topic: 9: Batch importing items in the database 

 

If you have many products or accessories to import to your PlanogramBuilder database, you 
can use the import commands to add or modify multiple items in one shot. 

 

 

The Import L+I command lets you add or update items in the PlanogramBuilder database 
from a spreadsheet file on your computer. It also uploads the item image files referenced in 
your input file.  

The Import L command does the same, but without uploading the image files. Any image 
column present in your input file is simply ignored. 

Important Tip: As a starting point to prepare your Item List for import, we strongly 

suggest exporting the current database from PlanogramBuilder and then using the 

https://www.youtube.com/watch?v=QXx1rRwjENk
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exported file as a template for importing. This is especially useful to easily get the proper 

header names if you have set the user interface to a language other than English. 

Tip: Once you have successfully tested batch importing some items, we advise to Clear 
Database to remove the sample products and accessories provided by zVisuel before importing 

your own products. 

Here are the instructions to prepare your data for import: 

1. Create a spreadsheet with one line per product or accessory, and define a column for 
each item property labeled exactly as in Database Editor. To import values into your 

Custom Properties, the header of each column must match exactly the labels that you 
have set in the Settings (see Database Setup). A description of each available property 
is available in the section Database Item Properties. 

Example of spreadsheet for import 

Reference Category Brand Product line Name Width Height Depth Image Shape Behavior Color Type 

045631 Beverage Coca-Cola Zero Coca-Cola Zero 500ml 6 20 6 045.png cylinder standard #ff0000  

054256 Beverage Coca-Cola Cherry Coca-Cola Cherry 500ml 6 20 6 042.png cylinder standard   

136853 Beverage Sprite Cherry Sprite Cherry 330ml can 8 11 8 153.jpg cylinder standard #6C0232  

bjh002 Beverage Coca-Cola  Coke shelf strip 80cm 80 2.5 0.3 002.jpg box_front shelf_strip #6C0232 1 

2. In order to import accessories, an additional column with a header named Type must 
be present in the spreadsheet: if a cell in this column has the value accessory, the 

item will be imported as a accessory. Leave this cell empty or enter product for items 
that are products. 

3. Save your spreadsheet as an Excel file (*.xls or *.xlsx), or if you can’t save as Excel 

files from your application, save as a Unicode Text file (*.txt). (Note: legacy Tab 

Separated *.txt files are still supported as in past versions, but this format doesn't 
support non-Latin characters.) 

4. Place all the image files to upload in the same folder as your spreadsheet File, or in 

any of its sub-folder(s). If your images are already in a folder on a different path on 
your computer, you can also create a shortcut to this folder in the folder where the 
Excel file is located. This way you don’t have to copy the actual image files to the 
required folder. PlanogramBuilder will automatically upload the referenced images to 

the database upon import using these images. Please refer to Guidelines for Images for 
further instructions. 

 

Example of suggested folder structure for database import with images 

5. In PlanogramBuilder, go to the Database task, click on the Import Import L+I 

button, then select the spreadsheet file you have prepared and wait for all items to be 
generated. 

6. Your items are now shown in the Database list as well as in the Products and 
Accessories catalogs. 
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Warning: If you edit your spreadsheet in Excel, References (SKUs, Gencode or EANs) or other 

values expressed as long numbers or numbers starting with “0” may not display correctly, 
because Excel doesn’t support these numbers. In this case, as a workaround, you have two 
solutions: 

• If you want to save the file as native Excel files (xls or xlsx), set the cells containing 
such numbers to text so your item Reference will be displayed correctly. 

• If you want to save the file as Unicode text, you can add a number sign [#] as a prefix 
to an item Reference. PlanogramBuilder then automatically removes the first character 

upon import if it’s a [#] so your item Reference will be displayed correctly in 
PlanogramBuilder. 

Ex: A 13 digit reference code 0235485217568 is not supported as a number by Excel. So 

change the containing cell to text and Excel will then display it correctly. PlanogramBuilder will 
therefore also display 0235485217568 in its database after import. 

Notes: 

Cancelling the import in progress: You can cancel the command Import L+I by clicking on 

its icon when a batch image upload is going on. 

Column header names: The header name of each column in your spreadsheet must match 
exactly each available property in Database Editor. 

Column header names for non-English languages: If you have set the language of the 

user interface to a language other than English, the names of the database properties are 
displayed in the language you chose. When importing, you must also name your source 
spreadsheet column headers as they appear in your language in Database Editor. 

Non-Latin characters: You can use non-Latin characters for most text entries. For example, 
you can enter product names in Greek language. Please see Database Item Properties to find 
out which text columns support Unicode characters. 

Column order: The order of the columns in your spreadsheet does not matter for importing, 

as the importer compares the header values to match columns.  

Customizable properties: Please see the section Database Setup for help on defining the 
names of the 3 classification properties and the 3 custom properties in PlanogramBuilder. 

Product dimensions: You can force a measurement unit for the dimensions of your items by 
adding the unit abbreviation within square brackets after the header. Here are the 4 possible 
options: 

• No unit specified (example: Width). The unit used for import will be the current 

preferred PlanogramBuilder unit. See Measurement unit for details on this setting. 

• [mm] (ex. header: Width [mm]). The product width will be interpreted as millimeters. 

• [cm] (ex. header: Width [cm]). The product width will be interpreted as centimeters. 

• [in] (ex. header: Width [in]). The product width will be interpreted as decimal inches. 

Color column: Color values are specified using the corresponding HTML color code including 
the # sign. Please see the Database Item Properties for details on the Color property. 

Type column: Please see the Database Item Properties for details on the Type property. 

Rule to determine if an item will be added or modified 

For each item listed in your spreadsheet, the Reference property value determines this: 

• If an item Reference in your spreadsheet cannot be found in your PlanogramBuilder 
database, a new item will be created. 

• If an item Reference in your spreadsheet already exists in your PlanogramBuilder 
database, the item will be updated to match the values from your spreadsheet. 
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Rules for missing columns 

When you import an item, the only compulsory column in your spreadsheet is the Reference. If 
you omit other columns, PlanogramBuilder fills their values according to the following rules: 

• If the item Reference already exists in the database and the missing column value is 

already defined there, the existing database value is kept unchanged. 

• If the item Reference already exists in the database but the missing column value is not 
defined there, or if the imported item Reference doesn’t exist yet in the database, 
default values are applied for properties when applicable, otherwise values are left 

empty. 

Example 1: Add new items to the database from scratch. Create a spreadsheet with properties 
Reference, Name, Category, Brand, Product Line, Width, Depth, Height, Image and any 

additional optional columns if you wish. Then use the Import L+I command. 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       33

 

Example 2: Update the Names of several items that are already in the database by simply 

importing a spreadsheet with two columns: one with the existing References and one with the 
new Names. Use the Import L command. 

Example 3: Update several Database Item Properties such as Names, Category or Dimensions 

without re-uploading the item images. To accomplish this, use the Import L command. Any 
image column in your source file will just be ignored. 

Rules for empty cells 

When you import an item, if you leave some cells empty under supported columns, the 

corresponding existing database values are overwritten by default values if applicable, 
otherwise left as blank values. The same rule applies to new item References. 

Example 4: Remove images from one or several products by importing a spreadsheet with 

blank cells under the Imagecolumn. Use the Import L+I command. 

Example 5: Update images of products by importing a spreadsheet with new images 
referenced in the Image column. Use the Import L+I command. All images referenced in your 
file will be re-uploaded. Tip: If you only want to update images of some products, don’t put 

empty cells because this would remove the images from the corresponding products. Instead, 
create an input file with only the lines for products that need updated images. 

Example 6: Import a spreadsheet with blank cells under the Collisions column to reset all 
existing item collision values to the default (Yes). Use the Import L command. 

Example 7: Import new items from a spreadsheet with blank cells under the Behavior column. 
This will set all item behaviors to the default value (Standard for products, Panel for 
accessories). Use the Import L command. 
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Database Item Reference 

 

This section provides the complete reference to integrate products and accessories in your 
PlanogramBuilder database. 

The properties are listed in the same order they appear in the exported database columns. 

Database Item Properties 

 

Property Name (Column header) Property Value (Column content) 

Reference 

A compulsory unique reference code for each item. You can use the EAN, UPC, 
SKU code or any other unique reference. (ex: 045631) 

Note: valid characters are [0-9][A-Z][a-z][the space character]$&@=.,;-
_!^~)(][}{ 

Invalid characters are replaced by an underscore [_]. 

Note: the number symbol [#] is not allowed in Database Editor field, but can 
be used with a special meaning when importing or exporting the database. 

 

Classification property A *1 *2  

(ex: Category) 

(default value: empty) 

For each item, the value corresponding to the selected property. (ex: Drinks) 

Note: items with empty values are shown in the catalog as (undefined) for this 
classification property. 

Note: Items with values of different text cases are grouped in the Database 
Editor and Item catalogs. Ex: Toys and TOYS are grouped as the same value.  

Classification property B *1 *2  

(ex: Brand) 

(default value: empty) 

For each item, the value corresponding to the selected property. (ex: Coca-
Cola) 

Note: items with empty values are shown in the catalog as (undefined) for this 
classification property. 

Note: Items with values of different text cases are grouped in the Database 
Editor and Item catalogs. Ex: Lego and LEGO are grouped as the same value. 

Classification property C *1 *2  

(ex: Product line) 

(default value: empty) 

For each item, the value corresponding to the selected property. (ex: Zero) 

Note: items with empty values are shown in the catalog as (undefined) for this 
classification property. 

Note: Items with values of different text cases are grouped in the Database 
Editor and Item catalogs. Ex: skin and SKIN are grouped as the same value. 

Name *2 

(default value: empty) 

The name of the item as it will appear in the catalog. This is usually the actual 
product name as printed on the product packaging (ex: Coca-Cola Zero 
500ml). 

Note: For materials, if the value is empty, an initial Name is automatically 
assigned using the image file name without extension as basis. You can also 
assign your own Name if you prefer. 

Width *3  

(default value for products and  

accessories: 10cm/100mm/5in) 

 

the physical width of the item in the selected measurement unit (ex: 6).  
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Height *3   

(default value for products and  

accessories: 10cm/100mm/5in) 

 

the physical height of the item in the selected measurement unit (ex: 20). 

 

Image 

(default value: empty) 

For each item, an image can be used to achieve a more realistic look. 

This property is the filename + extension of the item picture. (ex: 
045631.png) 

Note: Pictures are not compulsory. If you don't have a picture, the product will 
appear as a solid color, white by default, with its name printed on the front if it 
uses the box shape. See Color below for details on this property. 

Note: The maximum supported size for image files is 5 MB. 

Note for batch importing: If you type in only the image filename without 
extension in your Excel file, the importer will try to automatically find your 
image with the supported extensions in the following order: png, jpg, jpeg, 
jpe, jfif, bmp, tif, tiff, gif, tga, ico. 

Please see Guidelines for Images for instructions to prepare your images. 

Behavior 

(product default: standard) 

(accessories default: panel) 

The Behavior property is specific to PlanogramBuilder. It determines how and 
where an item will be positioned when dragging it to the bay. 

Behaviors for products: 

Please see Product Behaviors for the list of possible values. 

Behaviors for accessories: 

Please see Accessory Behaviors for the list of allowed values.  

Note: The Behavior value can be overridden per facing in any planogram: see 
Item Info. 

Collisions 

(default value: yes) 

yes (checked in GUI): the item will collide with other items. 

no (unchecked in GUI): the item will be able to overlap other items in the 
planogram. It can be necessary to disable collisions for items that have 
overhanging parts or are slanted. 

Note: Collisions have no effect if the general collisions parameter in settings is 
disabled. See Collisions. 

Width gap [...] 

(default value: empty) 

Only applicable to products. Sets the horizontal gap between products with 

multiple facings wide. 

By default, products with multiple facings wide are placed with no gap between 
each others. You can however override this behavior by specifying in the 
database a predefined gap between items. 

 

Note: For products pegged on pegboard type panels, the value entered 
corresponds to the minimal gap: the product will be placed on the nearest 
hook guaranteeing this minimal gap. 

Note: The Width gap can also be overridden per facing in any planogram: see 
Item Info. 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       36

 

Height gap [...] 

(default value: empty) 

Only applicable to products. Sets the vertical gap between products with 

multiple facings high. 

By default, products are stacked along the height axis with no gap between 
each others. You can however override this behavior by specifying in the 
database a predefined gap between items. Example: a value of 1 will force a 
gap of 1 measurement unit (cm or inch) between each repetition of this 
product in height. 

Note: For products pegged on pegboard or slatwall type panels, the value 
entered corresponds to the minimal gap: the product will be placed on the 
nearest hook guaranteeing this minimal gap. 

Tip: This parameter is also very convenient if you want to represent products 
nested into each others on a pile. In this case, enter a negative value 
corresponding to the amount of space the product should be nested inside the 
one below. Ex: enter -3 for a bowl which is nested 3 units inside the bowl 
below itself. Each bowl on the pile with this reference will also use this value. 

Note: The Height gap can also be overridden per facing in any planogram: see 
Item Info. 

Lateral offset […] 

(default value: empty) 

Lateral offset (pegged products only) lets you shift products to the left or to 
the right. This is convenient when the product hanging tab is not centered on 
the product. 

Default empty value = 0cm or 0” 

value of 0 = the product is centered on the peg hole 

positive values = moves the product right 

negative values = moves the product left 

Note: The offset can be previewed in database Editor if Show Peg Hooks is ON. 

Vertical offset […] 

(default value: empty) 

Vertical offset (pegged products only) lets you shift products higher or lower 
by a specified distance. This is convenient to define the position of the hanging 
hole on a product.  

default empty value = a negative offset of 1cm or 0.39" 

value of 0 = the product top edge is aligned to the peg hole on the back panel 

positive values = moves the product up 

negative values = moves the product down 

Note: The offset can be previewed in database Editor if Show Peg Hooks is ON. 

Color 

(default value: empty.) 

Empty values are treated as if a 
white color was applied) 

The Color property lets you specify a solid color for each item in the database. 

The color has the following effect on items: 

If no image is specified for an item, the specified color is also applied instead 
of the image. The color is also applied in Schematic view in box & text mode. 

The color value is specified in the database using the standard HTML color 
codes (ex: #FF0000 for red). A complete reference of theses HTML color codes 
is available at http://www.colorpicker.com/ or https://html-color-codes.info/ 
for example. 

In Database Editor, the item color can also be picked from a color palette by 
clicking on the color swatch, or by activating and clicking the color picker tool 
over the item preview area. 

http://www.colorpicker.com/
https://html-color-codes.info/
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Caption 

(default value: empty) 

Applicable to accessories with the Tag behavior only. 

Enter the text you want to display on the selected Tag item. 

Allowed values are: 

A text string (ex: On Sale) 

[br]: insert a line break 

[position]: display the position of the nearest product. The number helps 
indentifying the product position and is the same value as in the Project Item 
List when choosing the Position column. 

[reference]: display the Reference of the nearest product.  

[name]: display the Name of the nearest product. 

[custom1]: display the Custom Property 1 of the nearest product. Replace 
[custom1] by the actual property name you defined in Item Custom 
Properties. Ex: [Weight] 

[custom2], [custom3], [custom4], [custom5] and [custom6]: same as 
[custom1] above, to display other custom property values. 

Any combination of the above values 

An empty value results in no text shown on the tag 

Example: On Sale ! [br] 20% OFF [br] [name] 

Note: Make sure to actually type the square brackets when applicable. 

Text height 

(default value: empty  

= auto-height) 

Applicable to accessories with the Tag behavior only. 

Enter a numeric value to set the selected Tag item caption height. 

The measurement unit used is the same as selected in Settings. 

Example: 0.3 

Note: with an empty Text height or a value of 0, an automatic allocation of the 
text height is applied based on the item height. 

Text color 

(default value: empty = black) 

Applicable to accessories with the Tag behavior only. 

Enter the color of text captions for the selected Tag item in hexadecimal 
format (with or without the # prefix, not case-sensitive). 

Example: #0000FF results in blue text captions. 

Note: with an empty value, text is black. 

Custom property 1 *1 *2 

(ex: Weight) 

(default value: empty) 

For each item, the value corresponding to the selected property. (ex: 5kg) 

Custom properties 2, 3, 4, 5, 6 *1 
*2  

(default value: empty) 

Same as Custom property 1. For each item, the value corresponding to the 
selected custom property. 

Enabled 

(default value: yes) 

yes (checked in GUI): the item is available in the product or accessory 
catalog.  

no (unchecked in GUI): the item exists in the database, but is not available in 
the product or accessory catalog.  

This is useful to prevent other users in your company from using some items 
in planograms, such as for products that are no longer sold but you may want 
to reactivate later. 
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Type 

(default value: product) 

The Type of item: 

product 

accessory 

This property can be used to Batch Import Database Items. In Database 
Editor, it corresponds to the radio button to toggle Products / Accessories. 

Accessory 

(default value: 0) 

Deprecated: now replaced by the Type property, but still supported for 
backwards compatibility. 

The Accessory property indicates: 

0 = Product  

1 = Accessory 

This property can be used to Batch Import Database Items. In Database 
Editor, it corresponds to the radio button to toggle Products / Accessories. 

 

Important Note: If you have set the language of the user interface to a language 

other than English, the above properties have different names. Ex: the Width property 
is named Largeur in French. 

Note *1: Please see Database Setup for details on these properties. 

Note *2: Denotes a property where you can use Unicode characters for non-Latin text values. 

Note *3: Please see Measurement unit for information on how to select your preferred 
measurement unit. 

 

Guidelines for Images 

 

For each product and accessory, one image can be used to achieve a more realistic 
representation. You can use existing images or take photos of your product.  

Please follow the instructions below to prepare your images: 

Choosing the right product view 

• take a picture of the product most representative face (usually the front face). 

• For Image2, Image3, Image4, Image5 and Image6 (shapes with multiple images), take 
a picture of the product other faces according to the chosen shape as documented in 

_Standard_3D_Shapes.  

Taking the pictures 

• Don't use a flash as it creates bright hotspots on the photo. 

• Take the picture straight on, not from an angle. 

Using a transparent background 

• PlanogramBuilder supports transparent backgrounds in images: the transparent area 
will be invisible when you place your product or accessory on shelf. 

• Note: the following image formats support transparency in PlanogramBuilder: 

• png and tif 32 bits with 256 levels of gray for variable transparency (alpha channel). 

• png and gif 8 bits with 1 transparent color. 

Cropping your images 
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• Auto-crop: if your images have a transparent background as explained above, 

PlanogramBuilder performs an automatic crop to remove the unwanted area 
surrounding the product.  

• Manual crop: images that don't have a transparent background should be cropped 

manually to the outer limits of your product (i.e. the image must be cropped so that the 
outline of the product touches the 4 edges of the image as much as possible). Please 
see the image examples below. 

Image formats and resolution 

• Save the picture in a supported format: jpg, png, bmp, gif or tif. (use only gif, tif or png 
for transparency support) 

• Each picture file must be smaller than 5 MB for PlanogramBuilder. Otherwise it won’t be 

uploaded. 

• Images are automatically downsized by PlanogramBuilder if larger than 786'432 pixels 
(=1024x768 or 500x1573 for example). Uploading images larger than this will not 
provide better quality. 

• Make sure the image size is just large enough to distinguish the desired detail. Typically 
you want to be able to read the text on the product or packaging. 

Batch importing products with images 

• If you intend to use the Batch Import feature, make sure you save your images in the 

same folder as your products *.txt list file, or in one of its child folders.  

• If you type in only the image filename without extension in your Excel file, the importer 
will try to automatically find your image with the supported extensions in the following 

order: png, jpg, jpeg, jpe, jfif, bmp, tif, tiff, gif, tga, ico. 

• Please see Batch Import Database Items for detailed instructions. 
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Please look at the examples of good and bad pictures below. The dotted lines represent the 
edges of each image: 
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Product Behaviors 

 

Four types of products can be created with PlanogramBuilder, each of them corresponding to a 
specific value for the database Behavior field. Here are the possible values, descriptions and 
images showing example products for each Behavior value: 

 Behavior value  Description Example 

standard 

(default value) 

A standard product. 

It sits on shelves. (ex: a bottle of soda) 

 

stackable 

This is the same as standard products except it  can be 
stacked onto different products which also have the 
stackable behavior.  

Use this behavior for all products which must often be 
stacked on or below different products. Note: a stacked 
product is centered laterally on the product below, so it is 
best suited for stacking different products of the same 
width. 

Do not use this behavior if you want to create vertical piles 
of the same product. In this case see instead Change 
Product Facing Count. Exception: if you have created 
project with products stacked as separate items, keep the 
stacked behavior for your products (typically projects 
saved before October 2019). 

 

tester 

A tester product. 

It sits on shelves, but is placed at the front edge of the 
shelf. You can place standard products behind it. (ex: a 
perfume tester, which will be placed in front the packaged 

perfumes) 

 

pegged 
A pegged product. 

It hangs on pegs. (ex: blister packs) 

 

Note: Even if you choose a language other than English for the user interface, the names of 

the behaviors remain as listed above. 

Accessory Behaviors 
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Several types of accessories can be created with PlanogramBuilder, each corresponding to a 

specific value for the database Behavior field. Here are the possible values, descriptions and 
example images showing sample accessories for each Behavior value (listed alphabetically): 

 Behavior value  Description Example 

bay header 

A accessory which snaps to the top of any back panel. 

Note: if the bay has no back panel, you cannot place a bay 
header. In this case we suggest creating a small back panel 

as a crossbar to support your desired bay header. 

Use this to place header panels above your back panels. 

 

panel 

(default value) 

A accessory which snaps onto the back of any bay. 

Note: if the bay has no back panel, the header can be 
positioned between the lowest and highest shelves. 

Use this to create posters, back cards or any other hanging 
POS. 

 

Shelf strip 

A accessory which snaps onto the front edge of any shelf. It is 
horizontally centered and aligned to the top of the shelf. 

Use this to create single shelf strips. 

 

sticker 

A accessory which snaps to the front of a shelf or shelf strip at 
any lateral position. 

Use this to create cards, typically used to show information or 
specials. 

 

tag 

A box which can be placed on the front edge of a shelf to 
display as a label for the actual product name, pricing or other  
text (no image). 

Tags have dedicated parameters: 

Caption 

Text height 

Text color 

See details for each above parameter in the Database Item 
Properties.  

shape defined 
This is a special behavior to use only if you have been 
instructed to.  

 

Note: Even if you choose a language other than English for the user interface, the names of 
the behaviors remain as listed above. 
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Projects 
Projects are planograms created and saved in PlanogramBuilder native format. They can be 
opened and edited only in PlanogramBuilder. 

Your planogram projects are stored on our remote servers. This lets you log in to 

PlanogramBuilder from any computer and always access all your projects. 

In this section we explain how to open, save, merge, share and manage your planogram 
projects. 

New Project 
1. Click on the New command in the upper left corner of the work screen. 

 

2. After clicking New, you will have an empty project. 

3. The Templates task will be automatically activated if you have previously created one 
or more template(s), so that you can start dragging templates to your new project (See 
Template Catalog). If you have not previously saved any template or if the Create Bay 

task is currently active, this task will be active so that you can start adding new bays. 
(See Create Bay.) 

Tip: this command is also available in the Project menu and Context menu > Project. 

Save Project 
To save the same project again after further editing, simply click the Save command. 

 

Tip: You can see if your current project has been modified since it was last saved by the 
asterisk (*) symbol appended to the project name on the upper toolbar. 

 

Tip: this command is also available in the Project menu and Context menu > Project. 

Save Project As 
To save your current project for future access: 

1. If you are working on a new project, click the Save As button. 
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2. Type a name for the project in the Name edit box and optionally a comment (such as 

your client’s name) in the Comment field.  

 

3. Click the Save button on the bottom toolbar or press the Enter key on your keyboard. 

 

4. When the operation is complete, you will see a confirmation message in the bottom 
toolbar. The project automatically becomes available in the list of projects. 

Once the current project has been saved, its name appears in the top of the work screen (as 

shown in the Screen Layout picture).  

Tip: this command is also available in the Project menu and Context menu > Project. 

Project List 

  

The project list is displayed when you click on Open Project or Manage Projects. It lets you 
view and select all your saved projects. 

 

Tip: the project list also opens if you click on Open or Manage in the Project menu or in the 

Context menu > Project. 
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Select Project 

To select a project, click on its line in the list. 

Use the Up/Down arrow keys to switch to the previous/next project. 

A maximum of 50 projects is shown on each page. If there are more than 50 projects, they are 
displayed on additional pages. To select another page to display, use the page navigation tools 

in the lower left corner of the panel:  

• Display a page by clicking on one of the 10 visible page numbers. 

• Display the previous/next page by clicking on the left/right arrow (shortcut key: Left/ 
Right Arrow). 

• Display the previous/next page set by clicking on the left/right 3 dots. 

Note: If your screen is small, scroll down to see more items.  

Sort Projects 
Click on the headers at the top of each column to sort the projects according to the column 

content. 

For example, to order the list by project names, click on the Name header. To order it by most 
recent modification dates, click on Date Modified. 

When you click again on a header, the order is reversed. 

Note: The last-used sort criteria and sort direction persist for your next session. 

Filter Projects 
You can also use Search Filters to display only projects matching specific criteria. All the text 
filters accept single or multiple keywords following these rules: 

• Multiple keywords must be separated by spaces 

• All keywords must be present 

• Keywords are not case sensitive 

• The order of keywords doesn’t matter 

Example: typing Special campaign in the Name Search filter box will display all the projects 
containing Special AND campaign in their name.  

To clear a text filter, click on the relevant Clear button (red cross). To clear a drop-down filter, 

select the asterisk in the list. 

Note: The Owner column and filter are only visible to users with shared projects enabled (see 
Sharing All Projects). 

Tip: You can switch the selected project in the list to the one above or below with the Up and 

Down arrow key on your keyboard.  

Tip: You can use the Enter key to open the selected project. 

 

Open Project 
1. Click the Open or Manage button on the upper toolbar. It will open a dialog with a list 

of your projects. (See Project List.) This command is also available in the Project 

menu and Context menu > Project. 
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2. Double-click a project to open it. Alternately, you can: 

3. Select a project in the list.  

4. Press Open on the bottom toolbar (shortcut key: Enter). 

 

5. You will be prompted to save unsaved work if any. 

6. Your project will appear in the viewing area. 

Add Project (Merge) 
You can also combine a previously saved project with the currently opened project: 

1. Click the Open or Manage button on the upper toolbar. It will open a dialog with a list 

of your projects. (See Project List.) 

 

 

2. Select a project in the list. 

3. Click on the Add button on the bottom toolbar.  

 

4. The bays and the content of the added project are automatically merged into the 

currently opened project. They are initially placed to the right of the existing bays but 
you can move them easily afterwards with the Edit Bay tool. (See Move Bays below.) 

 

Note: If your current project has Free bays OFF and you merge a Free bays project, Free bays 

will automatically be turned ON for the current project to allow positionning the merged bays 
correctly. See Free Bays (Bay Placement Mode). 

Manage Projects 

 

The Manage button gives you access to the project list with functions such as deleting 
projects or changing project properties. 
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Tip: this command is also available in the Project menu and Context menu > Project. 

Delete Project 
1. Click on the Manage button. It will open a dialog with a list of your projects. (See 

Project List.) 

 

2. Select the project in the list. 

3. Click on the Delete button. 

 

4. Click OK in the confirmation dialog.  

Note: it is not possible to retrieve a project once deleted. 

PlanogramBuilder features local backup and restore capabilities for your Projects.  

We advise performing regular backups so you can always retrieve projects in the event of 
accidental changes or deletion. 

Change Project Properties 
This section explains how to rename, classify and mark projects as locked. 

Project Name 
The Project name lets you edit the name of each planogram project. 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 

Project List.) 

 

2. Select the project to rename in the list. 

3. Edit the Name of the selected project in the edit boxes on the right of the screen.  

 

4. Click on the Update button to apply your changes. 

 

Project Comment 
The Project comment lets you enter or edit a descriptive comment for each planogram project. 
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1. Click on the Manage button. It will open a dialog with a list of your projects. (See 

Project List.) 

 

2. Select the desired project in the list. 

3. Edit the Comment of the selected project in the edit boxes on the right of the screen.  

 

4. Click on the Update button to apply your changes. 

 

 

Project Locked Status 
Any project can be marked as Locked to prevent modifying the project after it has been 
finalized. 

To set a project as Locked, follow these steps: 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 
Project List.) 

 

2. Select a project in the list. 

3. Check the Locked checkbox on the right of the screen under Project properties. 

4. Press the Update button on the toolbar to apply your changes. 

 

After marking a project as Locked: 

• A checkmark is added under the Locked column in Project List, in Manage Projects and 
Open Project, to the right of Date Modified. 

• The Save command is disabled for this project. It can still be opened, edited and saved 
as, but modifications cannot be saved over the existing project. 

• Nobody can delete any project that is marked as locked. 

Upon un-checking the Locked checkbox it becomes possible to save or delete the project. 

Note: If a PlanogramBuilder administrator activated the option Shared Projects (Share All 
Projects), only an administrator is able to uncheck the Locked box of any project marked as 
locked. Even if you were the original user who set the project as locked, as a standard user 

you won’t be allowed to un-publish it. 
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Project Classification 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 
Project List.) 

 

2. Select the project to classify in the list. 

3. Edit the value(s) of the selected project in the edit boxes on the right of the screen.  

 

4. Click on the Update button to apply your changes. 

Tip: If it’s a Template your project classification is also reflected in the Template catalog. This 

lets you organize your templates so users can browse them easily. 

 

Share Projects 
Several features let you Template Projects and/or share projects with other PlanogramBuilder 
users in your company: 

• Send a Project Copy 

• Template Projects and use the Template Catalog 

• Share All Projects 

The above features allow sharing planograms for further editing as explained in the sections 
below. 

Note: Of course you can also output finished planogram pictures and reports for people who 
don't have PlanogramBuilder. In this case see Publish. 

Send a Project Copy 
To send a copy of one of your projects to one or several other PlanogramBuilder user(s) in 

your company, follow theses steps: 

1. Click on the Manage button. It will open a dialog with a list of your planogram projects. 
(See Project List.) 

 

2. Select the desired project in the list. 

3. Under Send project parameters on the right of the screen, in the drop-down list next 
to Recipients, select the destination user(s). To select several recipients, just pick 

them one by one in the list. They will be added to the recipients text field just below. 
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Tip: If you or your colleagues don’t remember your user name, you can find it like this: 
PlanogramBuilder displays the current user name at the upper right of the work screen as 
shown in the blue circle below. 

   

4. Click the Send button. 

  

5. When the operation is complete, you will see a confirmation message in the bottom 
toolbar. The project automatically becomes available in the list of projects of the 
destination user(s) for opening and editing. 

Note: Once a project has been sent to other user(s), your original project and the sent project 

are totally independent from each other. The sent project is a copy with no connection to the 
original project. If you wish other users to see the evolution of your project, send the project 
again, or use a shared Template Project, or else share all projects with other users (see Share 

All Projects). 

Template Projects 
Templates are typically projects containing items that you and optionally other users want to 
re-use on a regular basis, such as your empty bays or guideline planograms. 

• Template projects can be displayed in a Template Catalog for easy drag and drop in 

Planograms. 

• Template projects also become instantly accessible to all other users who have access 
to the same PlanogramBuilder database, typically colleagues in your company. 

Only PlanogramBuilder Administrators can create templates, but standard users can see and 
open any existing template. 

Only the owner of a template project is allowed to delete or make modifications to it. Other 
users can open the template project, but they must save it under another project name if they 

wish to retain any changes they have made. This prevents users from inadvertently changing 
the original template. 

To set a project as template, follow these steps (Note: Only available to a PlanogramBuilder 
Administrator) 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 
Project List.) 

 

2. Select a project in the list. 

3. Check the Template checkbox on the right of the screen under Project properties. 
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4. Press the Update button on the toolbar to apply your changes. 

 

Note: A user can only assign his/her own projects as templates. 

Note: In Open Project or Add Project (Merge), template projects appear in the list of projects 

with a special checkmark under the column labeled Template. 

Template Catalog 

 

The template catalog is accessed by clicking on the Templates tab. It lets you view all your 
template projects as thumbnails. Any template project can then be merged into your current 

project by drag and drop. 

This feature is very convenient if you want to make available premade fixtures or guideline 
projects to all users in your company. 

 

The various elements of the Templates task work very much the same way as Product 
Catalog, with templates sorted by classification and a text search filter. 

Share All Projects 

Note: Only available to a PlanogramBuilder Administrator 
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If there are several PlanogramBuilder users in your company, the option called Shared 

Projects lets users share all their Planogram projects. 

To set your preference for Share Projects between users, follow these steps: 

5. Click on Settings. 

 

6. Under Settings affecting all users > Shared projects, select the desired option: 

 

Disabled: 

• Only projects you own and template projects are visible in Project List. 

• The name of the original project owner is not displayed in Project List (Open Project + 
Manage Projects). 

Administrators only: 

• Standard users can open, edit and save projects of all users. 

• PlanogramBuilder Administrators can open, edit and save projects of all users. 
Additionally they can manage all projects of all users: rename, delete, and set as 

Template / Locked.  

• The name of the original project owner is added under a new column labeled Owner in 
Project List (Open Project + Manage Projects). 

• You cannot open a project that is already opened by another user. You have to wait the 

project is no longer opened by the other user. 

All users: 

• Standard users can open, edit and save projects of all users. 

• PlanogramBuilder Administrators can additionally manage all projects of all users: 
rename, delete, and set as Template / Locked.  

• The name of the original project owner is added under a new column labeled Owner in 
Project List (Open Project + Manage Projects). 

• You cannot open a project that is already opened by another user. You have to wait the 
project is no longer opened by the other user. 

Note: No matter the setting for this option, Locked projects cannot be saved while the flag is 
ON, and Template projects can only be saved by their owner while the flag is ON. 

Tip: You can use this feature to manage the sample project provided with PlanogramBuilder: 

1. Select Administrators only or All users (maybe temporarily) 

2. Close the Settings panel 

3. Click on the Manage button on the upper toolbar 

4. Although you are not the owner of the project named sample planogram, you can see it 
and select it in Project List.  

5. Once this project selected, you can change any of its properties and even delete it.  

 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       54

 

Backup and Restore Projects 

Backup Projects 
Note: Only available to a PlanogramBuilder Administrator 

PlanogramBuilder lets you create a local backup of your projects. The backup includes all 

projects from all users in your company. 

To back up your planogram projects, follow these steps: 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 
Project List.) 

 

2. Click on the Backup button. This opens a file save dialog. 

 

3. Choose a local folder, optionally change the suggested file name and the Excel file 
format. 

4. Click Save to create the backup Excel file. 

Tip: Before backing up projects, make sure to display the projects of all users in your project 
list. To do so, enable Share Projects for administrators (see Share All Projects). 

Restore Projects 
Note: Only available to a PlanogramBuilder Administrator 

PlanogramBuilder lets you restore projects from an existing local backup. The process restores 
all the projects listed in the input file. 

To restore your planogram projects, follow these steps: 

1. Click on the Manage button. It will open a dialog with a list of your projects. (See 
Project List.) 

 

2. Click on the Restore button. This opens a file open dialog. 

 

3. Choose the folder and the Excel file corresponding to the projects to restore. 

4. Click Open to restore the projects. 

What happens exactly when you restore projects 

• Projects listed in the input file and that don’t exist in your project list are added to your 

project list. This is typically the case with projects that were deleted after your last 
backup. 
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• Projects listed in the input file and that already exist in your project list overwrite the 

respective projects in your project list. Any changes made after the date of the input 
backup file will be lost. 

• Projects that already exist in your project list but not listed in the input file are left in 

your project list. No project is deleted. 

Editing the Excel input file 

The restore command must always use as a base an input file created by the backup 
command, but you can edit the Excel input file to update some project information and to 

remove any project that you don’t want to restore. To do such, open the input file in your 
Spreadsheet application and optionally do the following: 

• Delete one or several lines to prevent restoring some project(s). This way you can keep 

only the lines corresponding to the project you want to restore. Warning: very large 
projects can be on multiple lines. In this case, keep the line(s) with checksum 0 with 
the last line (showing a different checksum) of the project together. 

• Edit values in any of the following column: Name, Comment, Date Created, Date 

Modified, Template, Locked, Owner, Sender, Category, Brand, Product Line. If you 
change values in these columns, make sure to use the exact same format as other lines 
and enter values that make sense. For example, don’t enter a non-existing username in 
the Owner field. 

• Important: Never edit the following columns: Project #, Data, Checksum. 

• Use Save As…, not Save to save your modified file: this way you will still have the 
original backup file. 

Important Tip: Before Restore Projects, make sure to create a backup so you can revert in 
case something goes wrong. 

Tip: Before Restore Projects, make sure to display the projects of all users in your project list. 
To do so, enable Share Projects for administrators (see Share All Projects). 
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Screen Navigation 
In this section we explain how to navigate in the viewing area. 

Zoom 
To zoom in the viewing area, select the Zoom tool. Click and hold your mouse button down on 
the viewing area, then move your mouse up to zoom in or down to zoom out. (Shortcut key Z) 

You can also scroll your mouse wheel to zoom in and out (when the mouse cursor is within 
the viewing area). This method provides a convenient temporary zoom while keeping the 

current tool active (such as the Edit tool). 

Note: When you zoom in, the scene is centered on the location of your mouse pointer. 

 

 

Tip: this tool is also available in the Navigation menu and Context menu > Navigation. 

Pan 
Use the Pan tool to move the scene left, right, up or down. Click and hold your mouse over 
the viewing area and move your mouse in the direction you wish to move. (Keyboard shortcut 

P) 
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Tip: this tool is also available in the Navigation menu and Context menu > Navigation. 

Default 
The Default (View All) command resets the viewing area to a predefined view which fits all 

visible elements in your planogram. (Keyboard shortcut A) 

 

  

Tip: this command is also available in the Navigation menu and Context menu > 

Navigation. 
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Selected 
Selected zooms to fit the currently selected item(s) on screen 

 

 

Tip: this command is also available in the Navigation menu and Context menu > 

Navigation. 
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Undo / Redo 
 

 

 

 

 

 

PlanogramBuilder supports multiple undo and redo of planogramming operations on rooms, 
room elements, bays, bay elements, products and accessories. 

You can also undo and redo text typed in text boxes provided the mouse cursor is within the 
text box. 

Undoing your Changes 
You can reverse one or several of your previous actions by using the Undo command. 

 

Tip: this command is also available in the Edit menu and Context menu > Edit. 

Tip: you can also use the standard Ctrl+Z keyboard shortcut. 

Redoing your Changes 
The Redo command re-applies operations that were canceled by the Undo command. 

 

Tip: this command is also available in the Edit menu and Context menu > Edit. 

Tip: you can also use the standard Ctrl+Y keyboard shortcut. 
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Create Bay 
 

Video tutorial on this topic: 10: Creating and managing bays 

 

The Create Bay task is where you define and add new fixtures to your planogram projects. In 
PlanogramBuilder, bays are parametric objects that you can build as per the specifications of 
real fixtures found in your point of sales.   

The basic characteristics of new bays (gondolas) are specified here and will apply to all new 

bays until you change settings again. You can then further customize existing bays in the 
Modify Bay task. 

New Bay Parameters 

 

Before you add a new bay to your planogram, specify its parameters in this panel. A preview of 
the bay with is displayed in the upper right area. 

 

 

Note: the bay preview is displayed with visible edge lines to make each element clearly 
distinguishable. You can also turn this mode on in the planogram viewing area if you wish (see 
Show Edges). 

Note: the bay attributes will be kept for the next time you run the application. 

https://www.youtube.com/watch?v=C3twnqea9Cw


PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       61

 

Note: you can further customize bays in the Modify Bay task. For example you can add and 

remove, resize, re-position or change colors of bay elements. 

Bay Parameters 

 

 

Bay dimensions  

Specify dimensions as follows: 

Overall width specifies the horizontal width of the bay. You can also use decimals. 

The bay height can be specified with either one of the following methods: 

• Choose the Overall height and the Number of shelves if you know the bay height. 

• Choose the Gap between shelves and the Number of shelves if you the space between 
each shelf is more important than the overall height of the bay. 

Overall height sets the overall height of the bay. 

Overall height radio button: Upon typing a value for this parameter or manually checking the 
corresponding radio button, the Overall height will be constrained to the set value. This way, 

editing other values such as Number of shelves cannot change the Overall height of the bay, 
but will modify the Gap between shelves instead. 

Gap between shelves sets the vertical empty space between shelves. All shelves are evenly 
spaced. 

Gap between shelves radio button: Upon typing a value for this parameter or manually 
checking the corresponding radio button, the Gap between shelves is constrained to the set 
value. This way, editing other values such as Number of shelves cannot change the Gap 

between shelves, but modifies the Overall height instead. 

Number of shelves tells how many shelves the bay will feature. 

Note: Changing the number of shelves influences the Overall height if you checked the radio 
button in front of Gap between shelves. Inversely, changing the number of shelves modifies 

the Gap between shelves if you checked the radio button in front of Overall height. 

Main color 

Allows setting the color of the bay structure (base, back and sides). Click on a rectangle, and 

then choose a tint with the standard Color Dialog.  

Note: shelves have a separate color parameter, so you can make the shelves a different color 
than the rest of the bay. See Shelf color. 
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Shelf Parameters 

 

 

Shelf Dimensions 

Shelf width is the width of the shelves not including lateral sides. 

Shelf height specifies the thickness of the shelves. 

Shelf Color 

Allows selecting the color of the shelves. Click on a rectangle, and then choose a tint with the 

standard Color Dialog.  

Back panel Parameters 

 

 

Back Panel 

This check box specifies whether the bay has a back panel. You may not want one if the 
shelves are held by small cables for example. 

Back panel top margin 

Gives the vertical space between the upmost shelf and the top of the back panel. This setting 
also influences the bay total height. 

Side panels Parameters 

 

 

Side panels 

This check box allows choosing whether you want side panels on the bay. This setting also 
influences the overall bay width. 

Side panel width 

Represents the thickness of each lateral side panel. 
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Add Bay 

 

To add a new bay to your current planogram: 

1. Activate the Create Bay task. 

2. Set the New Bay Parameters. 

3. Click on Add to put the new bay in your planogram. 

 

The bay is placed at the center of the scene if there is space, otherwise to the right of any 
existing bay. 

Clicking Add several times will create exactly the same bay. 

Tip: Just after you have defined and added the desired bays to the viewing area, it can be 
useful to save the project with the empty bays to be re-used as a template. You can name it 
for example "Template bays for store X"; then you just need to drag that template from the 

Template Catalog to start a new project with the same bays. 

Tip: To create new bays, you can also copy existing bay(s) from your planogram and modify it 
/ them if necessary. 

Tip: this command is also available in the Edit menu and Context menu > Edit. 
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Modify Bay 
 

Video tutorial on this topic: 11: Editing bays 

 

The Modify Bay task is where you can edit existing bays in your planograms. 

This is often necessary to obtain the exact desires bay dimension and properties. 

There are two main tools in this Task: 

• The Edit Bay tool to edit whole bays. 

• The Edit Bay Element tool to work with sub-elements such as shelves and back 
panels. 

Tip: these tools are also available in the Edit menu. 

By default the Edit Bay Element is active when you activate the Modify bay task. 

Note: It is possible to disable bay editing for Standard Users. See Locked Bays for Standard 
Users. 

Bay Editing Options 

 

 

There are some main options which will affect the way bays can be edited and placed in your 
planograms. 

Free Bays (Bay Placement Mode) 
In PlanogramBuilder, you can choose to place your bays in two different modes depending on 
your needs: 

Free Bays OFF 

In this mode, bays are always placed adjacent to each others. This mode is well suited for 
planogram projects that represent a single store aisle. 

To turn the Free Bays mode OFF, do the following: 

1. Open the Edit Menu. 

2. Uncheck the menu item labeled Free Bays. 

3. The Free Bays menu item shows no checkmark if the mode is OFF. 

Here is an example of bays with Free bay OFF below: 

https://www.youtube.com/watch?v=o9t9UX3miS8
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Free Bays On 

In this mode, each bay can be freely positioned in your planogram project. This mode is well 
suited for planograms that represent a more complex retail area, such as non adjacent bays. 

To turn the Free Bays mode ON, do the following: 

1. Open the Edit Menu. 

2. Check the menu item labeled Free Bays. 

3. The Free Bays menu item shows a checkmark if the mode is ON. 

Here is an example of Free bay ON below: 

 

Note: The selected mode is saved with the current project.  

Note: Free bays is turned OFF by default for new projects. 

Warning: Turning Free bays OFF in a project that contains freely positioned bays will reposition 
all bays to be aligned and adjacent to each others. 

Note: If your current project has Free bays OFF and you merge a Free bays project (Add 
project), Free bays will automatically be turned ON for the current project to allow positionning 

the merged bays correctly. 

Tip: this tool is also available in the Edit menu and Context menu > Edit. 

Locked Bays for Standard Users 
Note: Only available to a PlanogramBuilder Administrator 

It is possible to completely disable all bay creation and editing features for Standard Users. 
This is typically useful when one or more PlanogramBuilder Administrator(s) is (are) in charge 
of creating the bays and make them available to other users as templates or share all Projects. 
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To disable bay access to Standard Users: 

1. Click on Settings.  

 

2. Under Settings affecting all users, un-check Standard users can edit bays. 

When checked, the following applies: 

Standard Users can access the Create Bay and Modify Bay tasks and commands to create 
and edit Bays. 

When un-checked, the following applies: 

The Create Bay and Modify Bay task tabs are hidden to standard users. Only 

PlanogramBuilder administrators can see these tabs, hence only them can create and edit 
bays. 

All menus and actions related to bay editing are also disabled for standard users. (Ex: B key 

has no effect.) 

Front Panel Visibility 
You can toggle the visibility of all front panels. Hiding front panels lets you select and edit 
products behind the panels. See Show Front Panels. 

Peg Hook Visibility 
You can toggle displaying the hooks of pegged products. See Show Peg Hooks. 

Select Bays 

 

The Edit Bay tool lets you select elements and perform various operations such as editing the 

bay properties or moving and copying bays. 

To select Bay(s): 

1. Click on the Edit Bay tool (or with keyboard shortcut B, or from the Edit menu). 

 

2. Select Bay(s): 

• To select one bay, click on a bay in the viewing area. 

• To select multiple bays, hold Ctrl key + click on desired bays, or draw a rectangle 
with your mouse pointer across the desired bays. 

3. Selected bay(s) become(s) highlighted in blue and you can perform several tasks on 

the bays such as deleting, moving, changing dimensions, etc. You can also change 
common parameters on all bay elements of the selected bay(s). For example, assign 
one color to all bay elements without having to select each bay element separately. 

Tip: To deselect the bay(s), click in an empty area in the viewing area, or select another bay. 

Tip: this tool is also available in the Edit menu and Context menu > Edit. 

Keyboard Shortcut: B 
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Note: The keyboard shortcut and menu command activates the Edit Bay tool, but do not 

activate the Modify Bay task. 

Resize Bays 

 

Resize Bays with Mouse 

 

1. Click on the Edit Bay tool (or with keyboard shortcut B, or from the Edit menu). 

 

2. Select the desired bay(s). They (It) become(s) highlighted with round handles along 
the front-most surfaces. 

 

3. Grab a handle with the mouse button and drag it until your bay(s) reach the 
desired size(s). The corner handles let you resize in two directions, while the handles 
along edges let you constrain resizing to one direction. 
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4. Release the mouse button. The bay is resized. Note that shelf and divider spacing is 
automatically recalculated while maintaining the thickness of such elements. 

Note: bays are normally resized to 1 cm or 0.5” rounded position values. To resize a bay 

completely freely, you can hold the space bar while resizing, producing a slower motion and 
preventing dimension rounding. 

Tip: With Show Dimensions ON, you can display the dimensions of the resizing rectangle while 
resizing. This is useful if you know in advance the space to allocate to the bay element(s). 
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Tip: With Show Dimensions ON, you can also display the actual exact dimensions used by all 
bays. 
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Note: Handles are convenient for quick mouse editing but you can also specify precise values. 
See Enter Bay Dimensions. 

Enter Bay Dimensions 

 

 

Overall width and height set the size of the whole bay. The bay(s) is (are) resized according 
to the new values. Note that shelf and divider spacing is automatically recalculated while 
maintaining the thickness of such elements. 
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Move Bays 

 

Move Bays with Mouse 

 

You can move bays with the mouse. 

1. Click on the Edit Bay tool (or keyboard shortcut B, or in the Edit menu, or in Context 

menu > Edit). 

 

2. Select the bay(s) to move (see Select Bays). They (It) become(s) highlighted and a 
move pointer is displayed. 

3. Press and hold the mouse button with the pointer over the selected bay(s) and move 
the mouse to the desired bay position. 

4. Release the mouse button. 

The way the bays are moved depends on the state of the Free Bays (Bay Placement Mode): 

• With Free Bays Off: The bay(s) is (are) placed at the closest position available next to 
another bay or between two bays, pushing the other bays to make space. 

 

• With Free Bays On: The bay(s) is (are) moved at the selected position on the ground. 
If there are one or more other bays at this position, they may overlap. 

bays are moved to 1 cm (or 0.5”) rounded position values. 

To move the bay(s) completely freely, you can hold the space bar while moving, producing a 
slower motion and preventing position rounding. 
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Note: You can also specify precise values. See Enter Bay Position. 

Enter Bay Position 

 

In Free Bays mode, you can position bays with precise values: 

 

Position Y: the distance from the position 0 along the Y axis. The position 0 is shown by an 

indicator with the Y axis in green in your planogram when the Edit Bay tool is active. 

Position Z: the distance from the position 0 along the Z axis (vertical distance from the 
ground). The position 0 is shown by an indicator with the Z axis in blue in your planogram 
when the Edit Bay tool is active. 

 

Note: Each bay position is calculated from the lower edge of the bay at the mid-point of its 
width. 

See below an example of a bay with the reference point and axis shown. 
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Tip: You can select several bays and apply common new values to these bays together. 

 

Copy Bays 

 

You can copy bay(s) with your mouse. This copies only the bay(s) without any products or 
accessory that may be on the existing bay(s). 

1. Click on the Edit Bay tool (or keyboard shortcut B, or in the Edit menu, or in Context 

menu > Edit). 

 

2. Select the bay(s) to copy (see Select Bays). 

3. Hold the Ctrl keyboard key and press and hold the mouse button with the pointer over 
the selected bay(s) and move the mouse to the desired bay position. 

4. Release the mouse button at the position you want the copies. 

The way the bays are copied depends on the state of the Free Bays (Bay Placement Mode): 

• With Free Bays Off: The bay(s) is (are) placed at the closest position available next to 

another bay or between two bays, pushing the other bays to make space. 

• With Free Bays On: The bay(s) is (are) placed at the selected position on the ground. 
If there are one or more other bays at this position, they may overlap. For details on 
positioning the copied bays, see Move Bays and Rotate Bays. 
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Delete Bays 

 

To remove bay(s) from your project:  

1. Click on the Edit Bay tool (or keyboard shortcut B, or in the Edit menu, or in Context 

menu > Edit). 

 

2. Select the bay(s) to delete (see Select Bays). 

3. Press the Delete button or the Delete key on your keyboard (or the Delete command 
in the Edit menu or in the Context menu > Edit). 

 

Add Bay Elements 

 

 

In Modify Bay task, under New Elements, you can add the following bay elements to any 
existing bay: 

• Back panel: a fixture element onto which you can place pegged products and 
accessories (panel). Drag it to the bay from the New Elements pane. 

• Divider: a vertical separation to create pigeon holes or side panels. Products will not be 
allowed to cross this element if Collisions is ON for the bay element. 

• Or drag this element and disable collisions on its properties to create any structural 
fixture element with no specific planogramming function, such as feet, posts, etc. 

• Front Panel: a structural fixture element best used to represent front doors or other 

front panels in your bays. The advantage of this type of element is that it can be hidden 
in case you have products behind it (see Front Panel Visibility). 

• By default front panels span the height and width of the bay and are positioned on the 
front of the bay.  

• Shelf: a special fixture element onto which you can Add Products on Shelves and 
accessories such as shelf strips or price tags. 

 

To add bay elements: 

1. Make you have at least one bay in your planogram. Otherwise see Create Bay. 

2. In Modify Bay task, drag new elements from the palette to the bay. 

3. Change the properties of the bay elements if needed (see Bay Element Common 

Parameters). 
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4. Save your empty bay as a project if you wish to re-use it later. 

Select Bay Elements 

 

The Edit Bay Element tool lets you select elements and perform various operations such as 

editing the bay elements and their properties, or moving and copying elements. 

To select bay element(s): 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 

in the Context menu > Edit). Switching to the Modify Bay task also automatically 
activates this tool. 

 

2. Select bay element(s): 

3. To select one bay element, click on a bay element in the viewing area. 

4. To select multiple bay elements: hold the Ctrl key while clicking on desired bay 

elements, or draw a rectangle with your mouse pointer across the desired elements. 

5. The selected bay element(s) become(s) highlighted in blue and you can perform several 
tasks such as deleting, moving, changing dimensions, etc. 

Note: some bay elements that have very different properties cannot be selected together. 

Note: you can select multiple elements each belonging to different bays. 

Note: Selecting a bay (bays) with the Edit Bay tool also selects all its (their) bay elements, 
allowing you to set common parameters for all elements in one shot, such as a common color 

for example. 

Tip: To deselect the bay element(s), click in an empty area in the viewing area, or select 
another bay element. 

Resize Bay Elements 

 

Resize Bay Elements with Mouse 

 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 

in the Context menu > Edit). Switching to the Modify Bay task also automatically 
activates this tool. 

 

2. Select the desired element(s). They (It) become(s) highlighted with round handles. 
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3. Grab one of the handles with the mouse button and drag it until your element(s) reach 
the desired size(s). The corner handles let you resize in two directions, while the 

handles along edges let you constrain resizing to one direction. 
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4. Release the mouse button. 

Note: bay elements are normally resized to 1 cm or 0.5” rounded position values. To resize an 

element completely freely, you can hold the space bar while moving, producing a slower 
motion and preventing dimension rounding. 

Tip: With Show Dimensions ON, you can display the dimensions of the resizing rectangle while 
resizing. This is useful if you know in advance the space to allocate to the bay(s). 
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Tip: With Show Dimensions ON, you can also display the actual exact dimensions used by a 

bay by pressing on a handle of the desired bay. 
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Note: handles are convenient for quick editing but you can also specify precise values. See 
Enter Bay Element Dimensions. 

Enter Bay Element Dimensions 

 

 

Width lets you set the overall width of the element. 

Height specifies the height of the element. 

 

Move Bay Elements 
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Move Bay Elements with Mouse 

 

You can move selected bay element(s) laterally or vertically with your mouse: 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 
in the Context menu > Edit). Switching to the Modify Bay task also automatically 

activates this tool. 

 

2. Select the bay element(s). They (It) become(s) highlighted and a move pointer is 
displayed. 

3. Press and hold the mouse button and move the mouse to the desired position. The 
displacement is constrained either vertically or laterally depending on your pointer 

position. 

4. Release the mouse button when you are happy with the new position. 

 

 

 

Note: bay elements are normally moved to 1 cm or 0.5” rounded position values. For example 
if you move a shelf up from an original distance from the ground of 141.2 cm, it will be 
repositioned at a rounded new distance from the ground (ex: 163.0 cm). To move an element 

completely freely, you can hold the space bar while moving, producing a slower motion and 
preventing position rounding. 

Note: when you move shelves, there is no anti-collision to allow crossing other shelves even if 
there are products. 

Note: you can also specify precise values. See Enter Bay Element Position. 
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Enter Bay Element Position 

 

 

Lateral offset is used to shift the element left or right. The distance is measured from the 
center of the bay origin (the theoretical center of the bay) to the center of the element. 
Negative offsets move the element to the left, positive offsets move it to the right. 

Distance to bottom specifies the vertical distance from the bottom of the element to the 
bottom of the bay. Shelf elements are an exception for which the distance is measured from 
the top of the shelf, making it easier to specify the actual position of the shelf surface relative 
to the bottom of the bay (typically the floor). 

Space and Align Bay Elements 

 

You can apply various spacing and alignment presets to a group of selected bay elements. 

For example, you can select multiple shelves and space them all evenly vertically. 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 
in the Context menu > Edit). Switching to the Modify Bay task also automatically 
activates this tool. 

 

2. Select the desired bay elements. 

3. Open the Edit menu. 

4. Put your mouse cursor over Align and Space. 

5. Select one of the commands below: 

 

Each command redistributes the selected bay elements in space as per the command name.  

Note: For reference, you can find some example images of the same commands applied to 

products in the section Align and Space Items. 

Copy Bay Elements 
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You can copy selected bay element(s) by dragging it (them) with your mouse to a new 

position. 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 
in the Context menu > Edit). Switching to the Modify Bay task also automatically 

activates this tool. 

 

2. Select the bay element(s), press the mouse button while holding the Ctrl key and move 
the pointer to the desired position. 

Note: Copying bay elements with your mouse is convenient for quickly duplicating shelves or 
other panels. You can later specify precise position values for each element by changing their 

parameters. See Enter Bay Element Position. 

Note: Back panels and side panels element cannot be copied as their quantity is fixed for each 
bay. You can however add dividers to create elements similar to side panels. 

 

 

Delete Bay Elements 

 

To remove one or more bay elements from a bay: 

1. Click on the Edit Bay Element button (or keyboard shortcut S, or in the Edit menu, or 
in the Context menu > Edit). Switching to the Modify Bay task also automatically 

activates this tool. 

2. Select the bay element(s) to delete. 

3. Press the Delete button or the Delete key on your keyboard (or the Delete command 
in the Edit menu). 

 

  

Bay and Element Parameters 

 

Bay Parameters 
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You can set some parameters which apply to the whole selected bay(s). 

Dimensions and position and are already described in the linked sections. 

Bay Name 

This lets you enter a descriptive text for the bay. The name can be listed in published reports 
and be displayed as a label on the bay in Schematic View. 

Bay Front Image 

For any Bay, one image can be displayed on the front face of the bay for a more realistic look. 

To apply a picture to selected bay(s): 

1. Next to Front image, press the Browse button and select an image file on your hard 

disk. 

2. The image will only be displayed on elements of each respective bay that have 
Selected “element” > Show front image checked. The image is automatically 

stretched to fit the overall dimensions of the elements that have Show Front image 
checked.   

Note: Any type of element can display the image.  

Here is an example image and the resulting bay with the image applied to the base and the 

light box of the bay: 
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To remove a picture from a bay: 

1. Select the desired bay(s) or its (their) bay element(s). 

2. Press the Clear button (red cross) next to the image name. 

 

Bay Flow Direction 

For each bay you can optionally define and display its flow direction, hereby indicating which 
way people are most likely to travel in the aisle where the bay is located. 

Defining the flow direction of a selected bay: 

• to right: people walk from left to right of the bay seen from the front. 

• to left: people walk from right to left of the bay seen from the front. 

• undefined: the flow direction is not defined (default value). 

Note: Refer to Show Flow Direction to learn how to display flow direction arrows on the screen. 
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Bay Locked Bay Elements 

For each bay, it is possible to Bay Locked Bay Elements in order to prevent any modification to 

the bay. 

The effect is as follows: 

• The bay and its bay elements can still be selected, but their properties cannot be 
changed any more, except the parameters Locked Bay Elements and Locked 

Accessories. 

• Existing bay elements cannot be moved with the mouse. 

• Existing bay elements cannot be deleted from the bay. 

• Bay elements cannot be added to the bay by dragging from the palette. 

Note: If Locked bay elements is checked for a given bay, you will need to uncheck it if you 
wish to add or edit any bay element on this bay. 

Note: The value of Locked bay elements is saved with the project for each bay. 

Bay Locked Accessories 

For each bay, it’s possible to lock in place all the accessories that are already placed on the 
bay and to prevent adding any accessories to this bay. 

Let’s suppose you have created a bay with several accessories such as a bay header, panels 
and shelf strips. Locking the accessories will allow you to add and move products on the 
shelves without risking to displace the accessories at the same time. 

Note: If Locked accessories is checked for a given bay, you will need to uncheck it if you 
wish to move any accessories on the bay. 

Note: The value of Locked accessories is saved with the project for each bay. 

 

Bay Element Common Parameters 

 

 

All types of bay elements share some common parameters. 

Dimensions and position are already described in the afore-linked sections. 

The other common parameters are listed below. 
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Bay Element Color 

Color allows setting the color of the element. Click on the rectangular color swap, and then 
choose a tint with the standard Color Dialog.  

Bay Element Front Image Display 

Show front image determines if the bay front image is displayed on the front of the selected 
element(s). See Bay Front Image for details on assigning a bay image.  

Bay Element Collisions 

Collisions lets you choose if products and accessories should be blocked by the selected bay 
element(s) when they are moved against it. The Collisions setting has however no effect when 

moving bay elements against each other. bay elements can always overlap one another. 

Tip: Check Collisions for elements which should act as a physical barrier for products, such as 
vertical separations. 

Note: The bay element Collisions setting has no effect if the general Collisions parameter in 
Settings is disabled. 

Shelf Parameters 

 

 

Beside the Bay Element Common Parameters, shelves have some additional parameters 
described below. 

Shelf Lateral Overhang 

Allow lateral overhang determines if products and accessories can overhang the side edges 
of the shelves. 

• Unchecked: items cannot extend past the lateral edges of the bay element. 

• Checked: items can extend past the lateral edges of the bay element, but only by 
maximum half the item width.  

Tip: check this so your products can overlap on adjacent shelves, even on separate bays. 

Shelf Behind Products 

Note: This parameter only applies to PlanogramBuilder Light version. 

Checking Behind products moves the selected shelf behind products that are positioned on 

lower shelves. 
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                    Behind products OFF          Behind products ON 

Shelf Margins 

Margins define limits of the inner area of the shelf onto which items can be placed. 

Left margin sets a distance from the left edge of the shelf beyond which products cannot be 

placed. 

Ex: The default value of 0 lets you place products on the whole width of the shelf. 

Ex: A value of 8 lets you place products on the whole shelf except on the last 8 mm/cm/inches 
on the left part of the shelf. 

Right margin sets a distance from the right edge of the shelf beyond which products cannot 
be placed. The principle is the same as for the left margin.  

Shelf Gap to Shelf Below 

Gap to shelf below can be used to specify the vertical space between shelves. This is 
convenient to ensure enough vertical space based on your product heights. Entering a value 
for this parameter overwrites the Distance to bottom value. This parameter is not available for 

the lowest shelf of a bay.
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Back Panel Parameters 

 

 

Beside the Bay Element Common Parameters, back panels have some additional parameters: 

Back Panel Lateral Overhang 

Allow lateral overhang determines if products and accessories can overhang the side edges 
of the selected back panel(s). 

• Unchecked: items cannot extend past the lateral edges of the panel. 

• Checked: items can extend past the lateral edges of the panel, but only by maximum 
half the item width.  

Tip: check this so your products can overlap on adjacent back panels, even on separate bays. 

Back panel Margins 

Margins define limits of the inner area of the back panel onto which items can be placed. 

The margins have different effects depending on the type of panel: 

• On Solid type back panels, the margins define the limits of the area which accepts 
items (shown as a dashed rectangle below). Items are constrained horizontally by the 
margins (unless Allow lateral overhang is checked), while vertically half of the item 
height is allowed to overflow the margin: 
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• On Pegboard and Slatwall type back panels, the margins define the limits of the area 
with peg holes or slats. Items can use all available peg holes or slat area (as visible 
with Show holes / slats enabled). Items are constrained horizontally by the back panel 

lateral edges (unless Allow lateral overhang is checked), but are not constrained 
vertically and can overhang above and below the back panel (as in the patato bag 
below). 
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Back Panel Type 

Type lets you choose various back panel styles.  

• Solid makes the back panel a plain surface. This means pegged products can be placed 
and moved freely on the back panel with no constraints. (Default value for new bays) 

• Pegboard turns the back panel into a pegboard. Pegged products will snap to the 

position of the peg holes on the back panel. By default, products are centered 
horizontally with the top edge aligned vertically to the peg hole. It is however possible 
to offset the product from the peg hole in the database or under Item Info. 

• Slatwall makes pegged products snap to the slats vertically, but still to be positioned 

freely horizontally. 

Depending on the type of panel, different options are available. 
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Pegboard example 

 

 

Slatwall example 

Back Panel Show holes / slats 

Show holes / slats toggles the visibility of the peg holes or slats on the back panel. Note that 
Show front image must be unchecked to enable this parameter. 

Back Panel Horizontal step 

Horizontal step applies to pegboards only. It defines the horizontal distance between holes 
on the pegboard. It acts as a snap grid increment to place pegged products. 

Back Panel Vertical step 

Vertical step applies to pegboards and slatwalls only. It is the vertical distance between holes 
or slats on the back panel. It determines the snap grid increment to hang products. 
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Products and Accessories 
 

 

 

In this section you will learn how to place products and accessories in planograms. 

Note: This topic covers three different tasks, Products, Accessories and Item Info. The 
functioning is very similar so we are grouping them in a single topic. In this chapter, we refer 
to products and accessories as item(s) whenever a topic applies to both types of items. 

Note: You must first add your own items to the database to start planogramming. If you are 

just starting using PlanogramBuilder, only sample items are available. Please see Database 
(Products, Accessories) to find out how to add your products and accessories to the database. 

Item Editing Options 

 

 

 

This section lists the options which affect the way products and accessories are placed and 
moved while planogramming. 

Collisions 
Collisions (or collision detection) mimic the real world by detecting and preventing any overlap 
between objects. With collisions activated, the following occurs when you drag, move or copy 
an item and position it: 

• If the desired item position overlaps another item, the item you are positioning can 
collide with the other item and push it automatically to make space if there is, or it can 
be blocked by the other item if there is no room to push it further. 

• If the desired item position overlaps a bay element, the item you are positioning can 

collide and be blocked by the bay element automatically.  

The collision feature can be enabled or disabled at various levels depending on your needs and 
preferences: 

Collisions Main setting 

You can disable collisions altogether if you prefer to be able to place products and accessories 
totally freely and let them overlap other items and bay elements when desired. This setting is 

per user and is remembered across sessions: 

1. Click on Settings. 

 

2. Under Settings affecting the current user only, Viewing & Editing, next to 
Collisions, check or uncheck the checkbox to enable or disable collisions. 
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3. Now close the settings and try to push a product against another one or against a 

divider bay element to see how they behave depending on the Collisions setting. 

Collisions per Database Item 

 

Note: This setting is only available to PlanogramBuilder Administrators. 

You can disable collisions permanently for specific products and accessories. This is useful 
when only some items must always be allowed to overlap other items.  

Collisions per Facing 

 

1. Select the items you want o change the collisions value. 

2. In Item Info task, check or uncheck Collisions. See Item Info. 

Toggling collisions against specific bay elements 

 

• Check the Collisions parameter for any specific bay elements to prevent products from 

overlapping them. See Bay Element Collisions. 

Collisions Override 

You can disable all collisions temporarily while placing products and accessories to avoid 
moving other items or being blocked inadvertently. This is typically useful when the item you 
are moving crosses other items or bay elements on its way to another location on the bay. 

• Press the C keyboard key when Move Items to temporarily disable collision detection. 

 

Tip: If you disable collisions, you may find it useful to highlight items that are overlapping. See 
Highlight Overlapping Items. 

Auto-Snap 

When you drag, move or copy an item on a shelf close enough to another item, it will 
automatically be re-positioned to touch the other item. 

Similarly, when you position an item close to the side edge of a shelf, the item will 
automatically be re-positioned precisely at the edge of the shelf.  

The threshold for an item to snap to nearby items and to shelf edges can be specified in the 
Settings: 

1. Click on Settings. 
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2. Under Settings affecting the current user only, Viewing & Editing, next to Auto 

snap distance, type the threshold distance value for items to snap together. 

  

3. Now close the settings and try to move some products near each other to see how they 

behave. 

  

Example 1 above: If you set the distance to 4cm, a product placed further than 4cm away 
from another product will stay where you place it. 

 

  

Example 2 above: If you set the distance to 4cm, a product placed closer than 4cm away from 
another product will jump and snap adjacent to that product. 

 

 

Example 3 above: If you set the distance to 4cm, a product placed closer than 4cm away from 
the lateral edge of a shelf will jump and snap aligned to the shelf lateral edge. 

 

Note: Auto-Snap only affects products and accessories that are sitting on shelves. Pegged 
items don’t snap together. 

Tip: If you want to be able to place products very close to each other without 

snapping them together, enter a value of 0 in the setting.  
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Item Dimension Lines 

You can display the dimensions of any selected item. See Dimension Lines. 

Item Catalogs 

 

 

Product Catalog 

 

Select the Products task. Here you can access all the products that are in your database. 

Each product is represented by a thumbnail and a text description. 

 

 

 

Important Note: You must first add your own Products to your database to start 

planogramming. If you are just starting using PlanogramBuilder, only sample items 

are available. Please see Database (Products, Accessories, Materials) to find out how to 

add your products to the database. 

Accessory Catalog 
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Select the Accessories task. Here you can access all the props and accessories that are in 

your database. These can be for example bay headers, banners, shelf strips, custom POS, etc. 

Important Note: You must first add your own accessories to the database to put 

them in planograms. If you are just starting using PlanogramBuilder, only sample 

accessories may be available. Please see Database (Products, Accessories) to find out 

how to add your accessories to your database. 

Find Items by Classification 

 

 

On the left side of the screen, your products are listed in a hierarchical menu with 3 levels, 

each corresponding to a classification criterion. Clicking on the hierarchy on the left filters the 
products in the catalog on the right side. 

When you select an item in the 1st level of the hierarchy, only the items matching your choice 

are shown at the 2nd level, and so on for the 3rd level. 

Note: products with empty values for a given level in the hierarchy are shown in the 
(undefined) group this classification level.  

Tip: You can display all items for any of the classification level by selecting the “*” symbol. 

Tip: Navigate in the classification list with the keyboard: 

• Move up/down in the list content with the Up/Down arrow keys. 

• Move down in the classification levels with the Tab key. 

• Move up in the classification levels with the Shift+Tab key combination. 

Find Items by Text 

 

 

Just above the catalog thumbnails, you can type some text to search and display matching 
products. When using this method, the hierarchy will be disabled and PlanogramBuilder will 

look in your entire database to find products matching the text you entered. The search box 
accepts single or multiple keywords following these rules: 

• Multiple keywords must be separated by spaces 

• All keywords must be present 

• Keywords are not case sensitive 

• The order of keywords doesn’t matter  

Example: typing frozen CHOCOLATE in the Search by Name box will display all the products 

containing chocolate AND frozen in their name.  

To get back to the classification method, you can clear the search box with the Clear button. 

Note: The search function is labeled and applies your text search according to the current type 
of thumbnail captions. Ex: if you have set your captions to show the product name and 

reference, the search will look for your text string in the list of product names and references. 
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Catalog Captions and Search 

The text description below each thumbnail can be set to be any combination of the following 
item properties: its name, reference, and/or any of the custom properties value as defined in 
the database. 

To set which property (ies) is (are) displayed below the thumbnails: 

1. Click Settings 

2. Under Product & Accessory Catalogs, Captions & search, check your preferred 
description, as shown below. 

 

Note: This setting doesn’t apply to the Template catalog, which always shows project names. 

 

Add Items 

 

 

This section describes how to place new products, accessories and generic products in a 
planogram. 

Add Products on Shelves 

 

To place a product defined with the standard, stacked or tester product behavior on a shelf: 

1. Activate the Edit Item tool by choosing the Products task (or keyboard shortcut I, or 
in Edit menu or in Context menu > Edit). 

2. Position the mouse pointer over on an item in the catalog. 

3. Hold the mouse button down and drag the item to a shelf in your planogram. 

4. Release the mouse button once you have reached the desired position. The item is 
placed on the shelf. 

5. Once a product has been placed in your planogram, its thumbnail background changes 

to a lighter color in the catalog, helping you identify already used products. 
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When you place a product with the standard or stacked behavior, one facing wide and one 

facing high is placed by default. 

After placing the item, you can change the number of facings with your mouse, keyboard or 
precise values. See Change Product Facing Count. 

Products with the tester behavior are placed in front of other products. 

 

Note: If there is no back panel on your bay, make sure to position your mouse cursor exactly 
on a shelf when you release the product, otherwise the product won't be placed on the shelf. 

Tip: You can add more than once the same object in a single drag & drop operation. While 

maintaining the left mouse button pressed, each time the mouse cursor is over a target 
location click with the right mouse button (press and release). Important note: this method 
does not create a block with multiple front facings, but it adds instead each product as a 

separate single facing. To create block of multiple adjacent facings of the same product, see 
instead Change Product Facing Count. 

Tip: Although the automatic collision feature is convenient, there are times when you may 
want to disable collisions. Please see Collisions for details.  
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Tip: When you add only products on shelves, you can lock accessories in place to prevent 

accidentally moving existing accessories. See Bay Locked Accessories. 

Tip: Products defined in the database with the pegged behavior are normally positioned 
automatically on pegs and will not sit on shelves. However, you can override the standard 

behavior and force a product to be sitting on a shelf by doing one of the following: 

• To add a product from the catalog, Shift+drag the product from the catalog to the 
bay. You will be able to drop the product anywhere on a shelf.  

• For product(s) already in your project and hanging on pegs, select the product(s), 

then change their product behavior to Standard in the Item Info task. 

 

Tip: you can set this property for several products in one click with Select Multiple Items. 

 

Add Products on Pegs 

 

To place a product with the pegged Product Behavior on a back panel: 

1. Activate the Edit Item tool by choosing the Products task (or keyboard shortcut I, or 

in Edit menu or in Context menu > Edit). 

2. Position the mouse pointer over on an item in the catalog. 

3. Hold the mouse button down and drag the item to a back panel in your planogram. 

4. Release the mouse button once you have reached the desired position. The item is 

placed on the back panel. 

5. Once a product has been placed in your planogram, its thumbnail background changes 
to a lighter color in the catalog, helping you identify already used products. 
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After placing the item, you can change the number of facings with your mouse, keyboard or 
precise values. See Change Product Facing Count. 

Tip: Products saved in the database with the standard, stacked or tester behavior can still be 

forced to hang to pegs by doing one of the following: 

• To add a product from the catalog, Shift+drag the product from the catalog to the 
bay. You will be able to drop the product anywhere on a back panel.  

• For a product already in your project and resting on a shelf, select the product(s), 

then change their product behavior to Pegged in the Item Info task. 

 

Tip: you can set the behavior for several products in one click with Select Multiple Items. 

Note: By default, the actual pegs are displayed in PlanogramBuilder. To toggle visibility of the 
hooks, see Show Peg Hooks. 

Tip: When you want to work only with products, you can lock accessories in place to prevent 
accidentally moving existing accessories. See Bay Locked Accessories. 

Add Generic Products 

 

Sometimes, you may need to include in your planograms some products that are not available 
in PlanogramBuilder database, such as seldom used competitors' products. In this case, 
PlanogramBuilder lets you create your own generic products: 

1. In the Products task, click on the Add button. 
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2. Place your mouse cursor over the area of a shelf where you want to add your new 
product. 

3. Click the left mouse button to confirm and create the generic product. 

 

 

Generic products are always presented as simple boxes with no image.  

Generic products have default parameter values upon creation. You can change their values 
after item creation in the Item Info task, for example the item name, dimensions, the number 

of facings or the behavior if you want to peg generic products. 

Note: Generic products are only saved in your current project, but not in the database. If you 
wish to add products to the database (so that they are shown in the catalog), please see 

Database (Products, Accessories) for detailed instructions. 

Tip: If you copy a generic product, it creates a new independent generic product which can 
then be edited to have different characteristics such as dimensions, name, etc. (see Copy 
Items). 

keyboard shortcut: N  

Menu item: Edit menu > Add Generic Product 

Generic Product Label 

In standard view a text label is displayed on the front showing the name of the product if has 
been defined. In schematic view, the label can show different information depending on the 
settings. 

You can also specify font for all the labels of generic products:  

1. click Settings on the upper toolbar: 

 

2. Set the options under Schematic View / Generic Products / Dimensions: 

Fontface 

  

This sets the typeface for the text labels. It also applies to text in dimensions, schematic view 

and on products in the database without picture. 

Font height 

 

This sets the text size for labels. It may be necessary to use a smaller text size if your product 
labels cannot be displayed fully with the default text size. 
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You can also fine-tune the font size interactively by selecting Font Size from the Display menu. 

With this tool, move your mouse left/right or up/down to change the font size. While the tool is 
active, you can click on the viewing area to reset the default value. 

Add Accessories on Bays 

 

It is very simple and straightforward to put products and accessories on their fixtures 

To place a accessory on a bay: 

1. Activate the Edit Item tool by choosing the Products task (or keyboard shortcut I, or 
in Edit menu or in Context menu > Edit). 

2. Position the mouse pointer over on an item in the catalog. 

3. Hold the mouse button down and drag the item to a bay in your planogram. 

4. Release the mouse button once you have reached the desired position. The item is 
placed on the bay. 

5. Once a accessory has been placed in your planogram, its thumbnail background 
changes to a lighter color in the catalog, helping you identify already used products. 

When you put a accessory, it is placed according to its behavior. For example, a bay header is 

placed at the top of the bay, while a shelf strip is placed at the front edge of a shelf. See 
Accessory Behaviors for reference on all available accessory types. 

 

Tip: You can add more than once the same object in a single drag & drop operation: while 

maintaining the left mouse button pressed, each time the mouse cursor is over a target 
location click with the right mouse button (press and release).  

Tip: Although the automatic collision feature is convenient, there are times when you may 
want to disable collisions. Please see Collisions for details.  

Select Items 
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In Products and accessories mode, you can select single or multiple objects to perform tasks 

on a group of objects in one operation. 

Select One Item 

 

 

 

1. Activate the Edit Item tool by choosing the Products task (or keyboard shortcut I, or 
in Edit menu or in Context menu > Edit). 

 

2. Click on the desired item in the viewing area. 

3. The selected item is tinted in blue.  

 

 

Select Multiple Items 

 

 

 

There are 4 methods available: 

Control + Click 

1. Select one or more item(s) (see Select Items). 

2. Hold the keyboard Ctrl key down. 

3. Select additional objects by clicking on each of them. 

4. The selected objects become highlighted in blue and you can perform operations on the 
selected group, such as deleting, moving, copying, aligning and spacing the objects. 
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Shift + Click 

1. Click on an object in the viewing area. 

2. Hold the shift key and click on a second object. Both items you clicked as well as all 
objects placed in-between become selected and highlighted in blue. 

 

 

Note: This method works similar to selecting files in Windows Explorer in list or icon view: you 
can select across multiple rows and bays; on each row, items are selected from left to right 

and then to the next row. 

Tip: You can edit the current selection set by doing another Shift+click. This redefines the 
range from the outermost object already selected to the latest item you clicked. 

Rectangle Selection 

1. Press the mouse button somewhere in the 3D area where there is no product or 
accessory. 

2. Keep the mouse button pressed and drag your cursor to another point in the 3D area: 
you will see a blue rectangle on the screen. 

3. Release the mouse button and all the items that are within or cross the blue rectangle 
become selected. 
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Rectangle selection           Result 

Tip: When you want to work only with products, you can lock accessories in place to prevent 

accidentally selecting accessories. See Bay Locked Accessories. 

Tip: If you have created a front panel covering your shelves, such as a glass door on a cooler, 
you may not be able to select any products behind the front panel. Please see Front Panel 
Visibility for help. 

 

Select All Products 

This method works only for products, not accessories: 

1. Open the Edit menu or the context menu > Edit. 

2. Click on the command named Select All products. 

 

3. All products in your planogram are now selected. 

 

Deselect Items 

 

 

 

Remove Items from a Selection 

1. Activate the Edit Item Tool by choosing the Products task (or keyboard shortcut I, or 
in Edit menu or in Context menu > Edit). 

2. Click on the item to deselect or draw a rectangle while holding the Ctrl key pressed. 

Deselect all Items 
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1. Activate the Edit Item Tool by choosing the Products task (or keyboard shortcut I, or 

in Edit menu or in Context menu > Edit). 

2. Click in an empty area in the viewing area. 

Change Product Facing Count 

 

 

By default, PlanogramBuilder places each product on the bay with one facing wide and one 
facing high. 

You can then change the number of facings in each direction for selected products in a 
planogram. 

Example: a product with 4 facings deep 

Facings Wide specifies the number of times products are duplicated horizontally for the 
selected facing(s).  

 

Example: a product with 3 facings wide 

Facings High specifies the number of times products are duplicated vertically for the selected 
facing(s). 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       108

 

 

Example: a product with 2 facings high 

Tip: you can also change the facing count with the keyboard or Mouse. 

Note: Facings wide and facings high count only applies and can only be changed for a facings 
block which forms a single selectable item. This means that products originally placed on the 
bay as separate items will remain so and cannot be grouped in a single item with multiple 
facings, even if they are adjacent. This may be the case for example if you open older projects 

which did not support the facings wide and facings high parameters. 

Note: The number of facings deep placed when you drag a product from the catalog can also 
be pre-defined in the database for each item. This is useful if you know in advance the number 
of facings deep you want for a given product. In this case see Database Item Properties. 

Change Facing Count with Mouse 

 

 

1. Select the desired product(s) (see Select Items). They (It) become(s) highlighted with 
round handles 
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2. Grab a handle with the mouse and drag it in the desired direction(s) until your 

product(s) reach the desired facing count. The corner handles let you change facings in 
two directions; while the handles along edges let you constrain the change to one 
direction. 
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3. Release the mouse button when you are satisfied with the number of facings. 

 

Tip: With Show Dimensions ON, you can display the dimensions of the resizing rectangle while 
resizing. This is useful if you know in advance the space to allocate to the product. 
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Tip: With Show Dimensions ON, you can also display the actual exact dimensions used by each 

facing block by pressing on a handle of the desired facing block. 
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Change Facing Count with Keyboard 

 

 

To change the Facing Count with the keyboard: 

Facings wide: Hold the Shift key and press the + and – keys on your numeric keypad. 

Facings high: Hold the Space key and press the + and – keys on your numeric keypad.  

Specify Precise Facing Count  

 

You can enter precise values to edit the Facing Count in Item Info task. 

Facings wide: Enter a value or use the plus and minus buttons. 

Facings high: Enter a value or use the plus and minus buttons. 

Resize Items 

 

 

 

Resizing products and accessories is normally done in the database editor. 
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However there are some exceptions listed below. 

Resize Generic Products 

 

Since generic products are not defined in the database, you can resize them in Item Info. 

Resize Accessories to Bay Width 

 

 

This feature is useful to rescale shelf strips and bay headers so that they match the width of 
the bay. 

1. Select the desired accessories as shown in the example below (see Select Items): 

 

2. Open the Edit menu. 

3. Click on the menu item labeled Fit Bay Width: 

 

4. The selected accessories are now rescaled: 
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Move Items 

 

 

 

You can move products and accessories on your bays: 

 

1. Select the desired item(s) (see Select Items). They (It) become(s) highlighted and a 
move pointer is displayed. 

2. Press and hold the mouse button with the pointer over the selected item(s) and 
move the mouse to the desired new position, even to another bay. 

3. Release the mouse button. The item is now in the new position. 

 

 

If there is some empty space between products, it is very easy to close these gaps thanks to 
the anti-collision feature: select the product(s), then click it and drag it/them against the other 

products; it will push the other products along the shelf much like in the real world: 
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Tip: Although the automatic collision feature is convenient, there are times when you may 
want to disable collisions. Please see Collisions for details.  

Tip: if you have selected several objects, you can move them together with a single drag and 

drop mouse operation. (See Select Multiple Items.) 

Tip: See Auto-Snapping Items to change the way items are automatically positioned adjacent 
when they are close to each other. 

Note: If you have created a front panel covering your shelves, such as a glass door on a 

cooler, you may not be able to select any products behind the front panel. Please see Front 
Panel Visibility for help. 

Tip: When moving one or several products on a bay, you can invert their current placement 

mode (pegged or standard) by holding the shift key until you drop the products in position. 

For example: 

1. Select several products placed on a shelf 

2. Hold the left mouse button down and start dragging the products onto the bay back 

wall. 

3. Press and hold the Shift key  

4. Release the mouse button when the products are in position against the back wall. 
The products are now pegged. If you hadn’t pressed the Shift key, you could only have 

placed the products on a shelf.  



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       116

 

Tip: When you want to work only with products, you can lock accessories in place to prevent 

accidentally moving existing accessories. See Bay Locked Accessories. 

Align and Space Items 

 

 

 

 

There is a series of handy commands available to distribute multiple items and bay elements 
on the bay. To use them:  

1. Select several items (see Select Items) or bay elements (see Select Bay Elements). 

2. Open the Edit menu. 

3. In the Align and Space group, choose one of these menu items: 

 

Tip: These commands are also available in the Context menu > Edit > Align and Space. 

Note: Collisions are disabled when aligning or spacing items.  

Note: If you have created a front panel covering your shelves, such as a glass door on a 
cooler, you will have to hide front panels before selecting products. Please see Front Panel 

Visibility for help. 

Align and Space settings 
Settings > Viewing & Editing 

The following setting affect the way align and space commands are applied. 

Spacing applies within multi-facings 

(Spacing applies to each facing) 

This setting determines how products are spaced. It applies to the following commands: 

• Space Horizontally 

• Space Vertically 

• Pack Left On Shelf/Row 

• Center On Shelf/Row 
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• Pack Right On Shelf/Row 

• Fill Shelf/Row Width 

 

Checked: Each facing is redistributed in space no matter if it is part of a multi-facing block. All 

gaps between facings within product blocks are also adjusted to match the desired distribution. 
Use this setting if you want to obtain an even spacing between each facing, no matter if they 
are part of a same product block. 

Unchecked: The entire facing blocks are redistributed in space to match the desired 

distribution. The gaps between individual facings within blocks are however maintained as in 
the original. Choose this settings if you want to obtain an even spacing between product 
blocks, while being able to adjust separately the spacing between facings within blocks. 

Examples of both settings are shown in the next sections. 

Align and Space per Selection 

 

 

 

 

The following commands distribute products, accessories and bay elements within the physical 

limits of the selected objects. See Align and Space Items for usage. 

Note: you can also apply these commands to items placed across several bays if the bays are 
placed side by side, parallel and not too distant from each others. 

Align Left / Right / Top / Bottom 

          

        Original placement                           Align Left                                Align Right 
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        Original placement                           Align Top                               Align Bottom 

 

Space Horizontally / Vertically 

Examples with Spacing applies to each facing checked: 

          

Original place   Space Vertically            Original placement                 Space Horizontally 

 

Examples with Spacing applies to each facing unchecked: 

          

Original place   Space Vertically            Original placement                 Space Horizontally 
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Align and Space per Shelf / Row 

 

 

 

The following commands distribute products and accessories within the physical width of the 
corresponding shelf (shelves) or row(s). 

See Align and Space Items for usage. 

Note: you can also apply these commands to items placed across several shelves, rows and 
bays. The command is applied to all selected items but independently per shelf / row. 

Note: if you have allowed Shelf Lateral Overhang / Back Panel Lateral Overhang where the 

selected items are placed, PlanogramBuilder still tries to fit the items within the physical 
bounds of the shelves / rows. But if the selected items only fit on the shelf / row with an 
overhang, the minimal possible overhang is applied. 

Center on Shelf / Row  

Examples with Spacing applies to each facing checked: 

  

                  Original placement                                         Center on Shelf / Row 

 

Examples with Spacing applies to each facing unchecked: 

  

                  Original placement                                         Center on Shelf / Row 

Pack Left / right on Shelf / Row  
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Examples with Spacing applies to each facing checked: 

  

              Pack Left on Shelf / Row                                   Pack Right on Shelf / Row 

 

Examples with Spacing applies to each facing unchecked: 

  

              Pack Left on Shelf / Row                                   Pack Right on Shelf / Row 

Fill Shelf / Row Width 

Examples with Spacing applies to each facing checked: 

  

                  Original placement                                         Fill Shelf / Row Width 

 

Examples with Spacing applies to each facing unchecked: 
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                  Original placement                                         Fill Shelf / Row Width 

Mirror Products  

 

 

This command lets you invert the left-right order of selected products on each row or shelf. It 
is convenient for example when you change the flow direction. 

To perform this task: 

1. Select the products to mirror (see Select Items). 

 

2. Open the Edit menu. 

3. In the Align & Space group, click on the command labeled Mirror Products. 

4. Now the left-right order of all selected products is inverted on each shelf and row. 
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Tip: This command is also available in the Context menu > Edit > Align and Space. 

Note: This command only works on products, not on accessories. 

Rotate Products  

 

 

These commands let you rotate selected products by increments. 

1. Select one or more product(s) (see Select Items). 

Open the Edit menu.In the Rotate group, select one of these commands. 

 

2. The selected products have now been rotated. 

 

While in Products task or Item Info task, the Rotate clockwise… commands are also 
available as buttons in the Edit toolbar. 

 

 

The Rotate… commands rotate products in 90 degree increments. 

Note: Use Shift+click on the rotate icon to invert the rotation direction. 

Keyboard shortcuts: left and right Arrows 

 

The Product Upside Down command let you to rotate selected products by 180 degrees: The 
front face still faces you, but the product(s) is (are) then upside down. 

Keyboard shortcut: U 

 

Example of a rotated product: 
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                        initial orientation                             270 degree Y rotation 

 

Tip: These commands are also available in the Context menu > Edit > Rotate. 

Note: If you have created a front panel covering your shelves, such as a glass door on a 

cooler, you may not be able to select any product behind the front panel. Please see Front 
Panel Visibility for help. 

Copy Items 

 

 

 

In Products, Accessories or Item Info task, select the Edit tool to copy products and props. 

 

Copying is almost the same process as Move Items: 

1. Select the desired item(s) (see Select Items). 
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2. Hold the Ctrl keyboard key and press the mouse button over the selected items. 

3. Drag the item to the area where you want to place the copied item(s). 

4. Release the mouse button. 

 

 

Important note: Do not use the copy function to create a block of multiple adjacent facings 
of the same product. See instead Change Product Facing Count. 

Note: Anti-collision is automatically disabled when Copying Items. 
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Tip: If you copy a generic product, it creates a new independent generic product which can 

then be edited to have different characteristics such as dimensions, name, etc. (see Add 
Generic Product) 

Tip: If you have created a front panel covering your shelves, such as a glass door on a cooler, 

you may not be able to select any products behind the front panel. Please see Front Panel 
Visibility for help. 

Replace Products 

 

You can replace a product already in your planogram by a product from the catalog. This lets 
you exchange products in a slot quickly without having to delete the replaced product first. 

To replace a product: 

1. Select the Products task and make sure the Edit Item Tool is active. 

2. Click and hold your mouse button on an object in the catalog. 

3. Maintain your mouse button down + hold the Alt keyboard key while dragging 

the item over the product to replace in your planogram. 

4. Release the mouse button and the product will replace the old product facings. 

 

Drag the new product over the product to replace. 
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The old product is replaced by the new product with fitting facings. 

 

Notes: 

When you replace a product, all parameters of the replaced facing(s) are transferred to the 

new facings (product behavior, facings gaps, …), except the number of facings which is 
automatically computed as follows: 

• The new product will have as many facings deep, wide and high as can fit in the space 
used by the old product facings. 

• If the new product is larger than the old facings block, it will still be placed if there is 
enough space between the neighboring items. 

• If there is not enough space between the neighboring items to place at least one new 

facing, the replacement isn’t performed.        

Ex: if you replace a product by one that has exact same dimensions, the same number of 
facings is placed in the space.  

Delete Items 

 

 

 

In Products, Accessories or Item Info task: 

1. Select the products and accessories to delete (see Select Items). 

2. Press the Delete button, or the Delete key on your keyboard, or the Delete command 
in the Edit menu or in the Context menu > Edit). 
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View and Edit Item Info 

 

The Item Info task lets you view the selected product or accessory properties and also 

override per facing some of the item properties that were pre-defined in the database. 

 

Tip: If multiple items are selected, the values you enter are applied to all selected items in a 

single operation. See Select Multiple Items for details. 

Tip: If you have created a front panel covering your shelves, such as a glass door on a cooler, 
you may not be able to select any products behind the front panel. Please see Front Panel 
Visibility for help. 

Item Properties 

 

Name, Width, Height, Color and Reference (see descriptions in Database Item Properties.) 

For products and accessories available in the database / catalogue, these properties are read-
only and shown for information only. You can still copy the values to the clipboard with 

Ctrl+C.  

For Generic products, the above properties are editable in Item Info because these items are 
not defined nor saved in the database.  

Behavior, Collisions, Width Gap, Height gap, Vertical offset, Lateral offset 

Although these parameters can be set in the database, you can also set or override the 
database values per facing in the current planogram project. This is convenient if you need to 
apply a non standard value for a special use case, for example to put a product on a shelf 

although it was defined as pegged in the database. Here are their descriptions: 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       128

 

Behavior 

Lets you change the way you want to place the selected product(s) on your fixture. See 
Product Behaviors for details on this property. Note: accessories behavior cannot be changed 

here, but only in the database. 

Collisions 

Can be enabled or disabled per item in your project for the selected products and accessories. 

See Collisions in the Database Item Properties for details on this property. Also see Collisions 
for various collision options. 

Width Gap 

Sets the horizontal gap between products with multiple width facings. This setting applies to 
the selected facing(s). 

Note: For products pegged on pegboard type panels, the value entered corresponds to the 

minimal gap: the product will be placed on the nearest hook guaranteeing this minimal gap. 

Height Gap 

Sets the vertical gap between products with multiple height facings. This setting applies to the 

selected facing(s). 

Note: For products pegged on pegboard or slatwall type panels, the value entered corresponds 
to the minimal gap: the product is placed on the nearest hook guaranteeing this minimal gap. 

Tip: You can enter a negative value to represent nested products, such as bowls. The value 
corresponds to the distance the product should “enter” into the one below. 

Example of bowls nested using a negative Height gap value 

Example of products spaced using a 3cm depth gap value 

Vertical offset 

Lets you shift products higher or lower by a specified distance (pegged products only). This is 
convenient to define the position of the hanging hole on a product. (Default: 1cm or 0.39") 

• value of 0 = the product top edge is aligned to the peg hole on the back panel 

• positive values = moves the product up 

• negative values = moves the product down 

Lateral offset 

Lets you shift products to the left or to the right (pegged products only). This is convenient 
when the product hanging tab is not centered on the product. (Default: 0cm or 0”) 

• value of 0 = the product is centered on the peg hole 

• positive values = moves the product right 

• negative values = moves the product left 

Caption 

Lets you specify a new text caption value for the special tag accessory. This value is normally 
defined by default in the database as described in Database Item Properties. 
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The Facings wide and Facings High parameters apply to products only. Their values can 
only be set per facing since they cannot be defined per item in the database. Here are their 
descriptions: 

Facings Wide 

Specifies the number of times products are duplicated horizontally for the selected facing(s). 
Enter a value or use the plus and minus buttons. 

 

Example: a product with 3 facings wide 

Tip: you can also change the facing count with the keyboard or Mouse. 

Facings High  

Specifies the number of times products are duplicated vertically for the selected facing(s). 
Enter a value or use the plus and minus buttons. 
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Example: a product with 2 facings high 

Tip: you can also change the facing count with the keyboard or Mouse. 
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Project Item List 
The Project Item List displays a list of all the items (products and accessories) in your project. 
It can be configured to display any available item property and several computed values. 

It also lets you select products and accessories in your project (one at a time). 

 

To display / hide the Project Item List: 

1. Open the Display menu or the Context menu > Display. 

2. Click on Project Item List. 

This list is also always opened in the Publish task because it is used to configure the Reports 
list content. 

The list panel can also be closed with the cross icon in its upper right corner. 

 

 

List Content Choice 
The Content Choice menu on the left of the list header bar lets you configure what is displayed 
in the list, as well as the grouping and highlighting of items. 

To display the Content choice panel: 
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1. Click on the right-pointing arrow next to Content choice. 

2. The panel is now displayed. 

To hide the Content choice panel: 

1. Click on the down-pointing arrow next to Content choice. 

2. The panel is now hidden. 

Type of Items 
Check the type of items you want displayed in the list: 

• Products 

• Accessories 

Columns 
Check the items properties you want to see listed as columns in the list. 

For each property displayed in the list, the value is shown for each item. Totals or average 
values per group and per project are also shown when possible for numeric and percentage 

values. 

 

The following properties are available: 

Picture 

Thumbnail: enable this column to display thumbnail images of each item in the list. 
Thumbnails can help identify each product visually in the listing. 

The thumbnail size is adjusted based on the selected font size. 

Position 

Position: this assigns numbers from 1 to n to each product listed. Numbering is assigned 

based on each item physical location with the following rules: 

• On each bay, numbering is ordered from the left-most product on the highest shelf/row 
to the left-most product on the lowest shelf/row. 

• If items are grouped in the list by Bay number or by Bay name, item numbering 

restarts from 1 at each bay.  

• If items are not grouped in the list by Bay number or by Bay name, a unique number is 
assigned to each item in the project. In this case numbering starts from items on the 

1st Bay number and ends with those on the last Bay number in the planogram. 

Tip: To quickly find the position of each product, the Position column can be combined with 
matching number labels on the products in schematic view. 

Bay number: a unique number assigned to each bay. Numbering starts from the left-most 

bay and ends with the right-most bay in the planogram as seen from the front.  

Bay name: the name of each bay as defined in Bay Name. If no name is defined for a given 
bay, its Bay name is displayed as Bay [Bay number], for example Bay 7 in the item list. 

Shelf/Row: when checked, a column shows on which shelf or row of the bay each product is. 
Note: Even empty shelves are numbered. 

Bay – Shelf: this provides a more compact version of item position, combining Bay number + 
Shelf / Row. Foer example 2-5 means the item is on bay 1, shelf 5. 
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Horizontal ID: a column numbering items from 1 to n from left to right on each shelf / row. 

All items stacked vertically in a same stack have the same horizontal ID value. 

Note: any item of same reference placed several times side by side and with the same values 
for Facings Deep and Facings High will account for a single horizontal ID. In this case the 

Facings Wide value is set to the number of adjacent piles of the item. See the corresponding 
Facing Wide/High/Deep definitions below. 

Description 

Enabled, Reference, classification (ex: Category, Brand, Product Line), Name, custom 
properties (ex: weight, country, etc), Color. 

See Database Item Properties for details on each of the above item properties. 

Dimensions 

Width, Height. 

See Database Item Properties for details on each of the above item properties. 

Type 

Type: the type of item, either Product or Accessory based on the type defined in the database 
for each item. 

Behavior: outputs each item behavior. For accessories, this is the item behavior as defined in 
the database (see Accessory Behaviors). For products, this is the item behavior as defined in 
the database, or the item behavior set per facing in the current project if different (see Product 

Behaviors). 

Arrangement 

Width gap, Height gap, Lateral offset, Vertical offset, Collisions: 

See Item Properties for details on each of the above item properties. 

Facings 

Facings Wide, Facings High 

The number of facings based on what is defined in Item Properties.  

The total facings are computed per block of same products, according to the following rules: 

• Adjacent Facings part of a facings block (single selectable entity) are grouped on 1 line 

with their total number of facings. 

• Adjacent facings part of separate facings blocks (multiple entities) are treated as 
separate facings (separate lines in the list) and listed on disctinct lines. 

• Different products stacked vertically are listed on disctinct lines. 

Space Used 

Linear space [cm] / [in]: the width used by each facings block on the fixture. 

For on shelf products (standard): linear space = facings block width. (in the case of shelved 

products with multiple facings high, each row uses the same shelf and backpanel slot, so we 
count only the base row of the stack as using linear space) 
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For pegged products: linear space = facings block width × facings high. (in the case of pegged 

products with multiple facings high, each row uses a separate backpanel slot, so we count each 
row as using linear space) 

Totals are expressed in the measurement unit selected in Measurement unit. 

Linear space [%]: the width used by each facings block expressed in percentage of the total 
space used by products on a given bay. 

for on shelf products (standard): linear space = facings block width. 

for pegged products: linear space = facings block width × facings high. 

Front surface [cm2] / [in2]: the front area (width × height) used by each facings block. This 
column also gives the total facing area used by all products on a bay. The values are 
expressed in the measurement unit selected in Measurement unit. 

Front surface [%]: the front area (width × height) used by each product expressed in 
percentage of the total area used by all products on a given bay. This column always gives a 
total area of 100%, corresponding to the area used by all products on the bay. 

Note: Linear space, Front surface are computed based on the space taken by each product 

block including the gaps between facings if any. For example, a product measuring 10cm wide 
× 8cm high placed as 2 facings wide × 2 facings high, with a width gap of 1cm results in this 
front surface: 

((10cm × 2 + 1cm) × (8cm × 2)) = 336cm2 

Grouping 
You can group items in the Project Item List by any available property. 

When using groups, sub-totals per group are also displayed for applicable columns 
(percentages and numeric values). 

To group items in the list: 

1. In the List content, under Columns, right-click on the property name by which you 
want to group items. For example, right-click on Bay number. 

2. A context menu is displayed. 

3. Select Group by Bay Number. 

4. The list of items is now grouped by Bay number. A group icon is also displayed in the 
Project Item List header bar showing the curent grouping property. 

To ungroup items in the list: 

1. Right-click anywhere within the Project Item List panel to show its context menu. 

2. Select Group by (None). 

To expand / collapse a group in the list: 

1. Click on the right-pinting / down-pointing arrow next to the group name in the list. 

To expand / collapse all groups in the list: 

1. Right-click anywhere within the Project Item List panel to show its context menu. 

2. Click on respectively Expand all groups / Collapse all groups. 

 

Example of grouped items: the screenshot in Project Item List shows an example of the list 
grouped by Bay name. 
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Highlighting 

You can highlight items in the Project Item List by any available property. 

1. In the List content, under Columns, right-click on the property name by which you 
want to highlight items. For example, right-click on Category. 

2. A context menu is displayed. 

3. Select Highlight by Category. 

4. The list of items is now highlighted by Category. A group icon is also displayed in the 
Project Item List header bar showing the curent grouping property. 

The products in the visual area are also highlighted by Category, and a color range bar is 

displayed above the visual area as a legend if applicable (for numeric and percentage 
values).To un-highlight items in the list: 

1. Right-click anywhere within the Project Item List panel to show its context menu. 

2. Select Highlight by (None). 
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Example of products highlighted by category in the Project Item list 

 

 

Example of products highlighted by category in the viewing area 

List Sort Order 
To sort the items in the list according to a desired column content: 

1. Click on the desired column header, for example Position. 

2. Click again to invert the sort order. 

 

To sort the list groups (if any) in the desired order: 

1. Click on the group header next to the group icon, for example Bay Name. 

2. Click again to invert the sort order. 
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List Column Order 
To re-arrange the order of columns in the list: 

1. drag any column header left or right to the desired position. 

List Presets 
This feature lets you save and apply your preferred Project Item List parameters. This is very 
useful to quickly switch between various types of lists to display on screen and to include in 

reports. 

The following list parameters are stored in the presets: 

• Type of items 

• Columns 

• Grouping 

• Highlighting 

• Sort order 

• Column order 

Save Preset 
To save the current Project Item List as a preset configuration: 

1. Right-click anywhere within the Project Item List panel to show its context menu. 

2. Move your mouse cursor on Presets 

3. Click on Save As…. 

4. In the List header, next to Preset:, type the desired name for the current clist 
configuration. 

5. Click on the Save button. 

6. The current list configuration is now saved and available for re-use. 

Apply Preset 
To retrieve and apply a previously saved preset: 

1. In the Project Item List header bar, next to Preset:, click on the preset list to expand 
it. 

2. Select the desired preset to apply it. 

Delete Preset 
To remove a previously saved preset: 

1. In the Project Item List header bar, next to Preset:, click on the preset list to expand 
it. 

2. Select the preset you want to delete. 

3. Right-click anywhere within the Project Item List panel. 

4. A context menu is displayed. 

5. Move your mouse cursor on Presets 
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6. Click on Delete to delete the current preset. 

List Panel layout 
You can move and resize the Project Item List panel. 

List Panel Position 
To move the Project Item List panel to a different location on screen: 

1. Right-click anywhere within the Project Item List panel to show its context menu. 

2. Move your mouse cursor on Position 

3. Click on Left, Right, Top or Bottom. 

4. The Project Item List is now placed in the selected location.  

List Panel Size 
To resize the Project Item List panel: 

1. Place the mouse cursor on the separation line between the list panel and the visual 

area. The cursor turns into a double-ended arow. 

2. Drag the separation line to the desired location on screen. 

3. The panel is now resized. 
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Display Modes and Options 
To change the way you look at your planogram (without modifying it), use the features 
detailed below. These features are available whenever you can see your planogram project in 
the viewing area. 

Schematic View 
When activated, this special view mode shows all the products in your project in a simplified, 
schematic view. 

Activate Schematic View 
1. Open the Display menu or the Context menu > Display. 

2. Click on Schematic View. (Keyboard shortcut V) 

 

3. In schematic view, text labels are displayed on objects as in the example below. 

 

 

Schematic View Settings 
Various options can change how items are displayed in schematic view. 

To set these options: 
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1. click Settings on the upper toolbar: 

 

2. Set the options described below. 

 

Note: The choices you make will be remembered for your next PlanogramBuilder session. 

Schematic View / Generic Products / Dimensions 

Fontface 

  

This sets the typeface for the text labels. It also applies to text in dimensions, on generic 
products and products in the database that use the box shape without picture. 

Font height 

 

This sets the text size for text labels. For example make the text smaller to fit the label text on 
your products.  

You can also set the font size interactively. See Font Size. 

 

Under Schematic View: 

 

Bay style 
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Show label displays the name of each bay on a label strip as shown below. Please see Bay 

Name to find out how to assign names to the bays. 

 

Product style  

box & label displays products as simple boxes with their caption printed on the front face: 

 

 

shape & label displays products with their 3D shape, picture and a caption printed as a label 
strip: 
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Group labels combines labels for groups of adjacent same products. 

When using Group labels with the box & label style, labels are grouped only vertically (ex: 
product no5) to help identify the products visually and prevent confusion since there is no 

visible product picture (ex: product no14): 

 

 

When using Group labels with the shape & label style, a single label is displayed for adjacent 
same products: 
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Label Position defines the vertical position of labels relative to each product. 

The following positions are available: 

• Above: the label lower edge is placed at the product upper edge. (Available only with 

the shape & label product style) 

• Top: the label upper edge is placed at the product upper edge 

• Center: the label is centered on the product 

• Bottom: the label lower edge is placed at the product lower edge 

• Below: the label upper edge is placed at the product lower edge. In this case, the label 
is also moved forward in front of the shelf to preserve readability. (Available only with 
the shape & label product style) 

• On shelf/peg: the label position varies depending on product style and the product 
behavior. 

• With shape & label product style: 

o Pegged products: the label lower edge is placed at the product upper edge. 

o Other products: the label upper edge is placed at the product lower edge. 

• With Box & label product style: 

o Pegged products: the label upper edge is placed at the product upper edge. 

o Other products: the label lower edge is placed at the product lower edge. 

Tip: Combined with the shape & label product style, the On shelf/peg label position 
resembles the way labels are physically placed in stores. 

 

Label color sets the color of the label background. 

Label text color sets the color of the label text. 
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See below some examples of label positions and color combinations: 

 

Label position: On shelf/peg 
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Label position: Top 
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Label position: Center 

 



PlanogramBuilder Light User Guide - Copyright © 2002-2022, zVisuel SA       148

 

 

Label position: Below 

Product label 

You can choose and combine information to display on the product labels: 

Position shows a label with the product position on the bay indexed from left to right, top to 
bottom. In reports, these numbers can then be published in Report Pictures and used in 
conjunction with numbers displayed in the Report List to easily identify items in the list and the 
picture. 
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Reference displays products with their unique reference printed on the front face. 

Name displays products with their name printed on the front face. 

Custom properties: up to 6 additional labels may be available depending on the custom 

properties defined for your database. Each of them shows products with the value of the 
selected custom property. See Item Custom Properties for help on these user definable 
properties. 

Font Size 
This tool lets you set the text size for text labels on generic products and products in 

Schematic view. For example make the text smaller if product labels don’t fit on your products.  

To change the font size: 

1. Select Font Size in the Display menu or in the Context menu > Display. 

2. Move your mouse left/right or up/down to change the font size. 

To reset the default value: 

1. Select Font Size in the Display menu or in the Context menu > Display. 

2. Left-click on the viewing area. 

Note: The text size can also be specified precisely in the settings. See Schematic View / 
Generic Products / Dimensions. 

Highlight Disabled Items 
Products and accessories can be disabled in the Database, so they aren’t displayed in the 
catalog (see Database Item Properties). However, if you open a project which contains 
disabled items, these are loaded and display on your bays because they still exist in the 

database. 

You can visually identify the disabled items in the current project as follows: 
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1. Open the Display menu or the Context menu > Display. 

2. Click on the command Highlight Disabled Items. 

 

3. Now you can see disabled items in red as in the example below. 

 

4. Simply click on this command again to disable it. 

Note: If you disable items in the database while they are in the currently opened project, the 
disabled items will only be highlighted when you reload the project. 

Highlight Overlapping Items 
This feature helps visualizing areas of physical overlap between products and between product 
and bay elements. 

This is especially useful if you have disabled collision detection, because in this case items can 
easily be mistakenly placed with overlaps. 

1. Open the Display menu or the Context menu > Display. 

2. Click on Highlight Overlapping Items. 

 

3. Now you can see a yellow color highlight on the products which overlap other products 
or bay elements. 
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Show Front Panels 
If you have created a front panel covering your shelves, such as a glass door on a cooler, you 
will not be able to select any products behind the front panel. In such case you can use this 
command to toggle the visibility of all front panels. Hiding front panels lets you select and edit 
products behind the panels. You can then display the front panels again once your planogram 

is ready to publish. 

1. Open the Display menu. 

2. Uncheck Show Front Panels. 

 

3. The front panels are now hidden. 

Tip: this command is also available in the Context menu > Display. 
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Show Peg Hooks 
This command toggles displaying the actual hooks of pegged products. Showing the hooks can 
help visualizing where the peg is located exactly, including any offset. 

1. Open the Display menu. 

2. Select Show Peg Hooks. 

 

3. The peg hooks are now displayed as shown below. 

 

4. Repeat the same command to hide the peg hooks. 

 

Tip: this command is also available in the Context menu > Display. 

Note: The offset can be previewed in database Editor if Show Peg Hooks is ON. 

Dimension Lines 
You can display onscreen the dimensions of your planogram bays, bay elements and items. 

Show Dimensions 
To Show Dimensions: 

1. Open the Display menu or the Context menu > Display. 

2. Select the menu item named Show dimensions. (keyboard shortcut D) 
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3. Depending on the context, various dimensions are displayed onscreen: 

By default, the overall width and height are shown for each isolated bay and each group of 
adjacent bays (bay clusters).  

 

Additionally, for each bay with at least one selected shelf, vertical shelf measures are shown. 
And for each bay with at least one selected divider, lateral distances between dividers are 
displayed. 
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The dimensions of any bay, bay element or product facing are also displayed when clicking on 

one of its round handle in the corresponding Edit mode. Example:  

 

 

To hide the Dimension Lines: 

1. Simply click on the Show Dimensions menu item again. 

 

Important: A dimension is only displayed if the available space allows. If you can’t see a 
desired dimension, zoom and pan the view to accommodate for it. 

Dimension Settings 
You can set the following parameters for dimension text and lines: 

1. click Settings on the upper toolbar: 

 

2. Set the options under Schematic View / Generic Products / Dimensions:  

Font face 

  

This sets the typeface for the Dimension Lines. It also applies to text labels on generic 
products, in schematic view and on products in the database that use the box shape without 
picture. 
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Dimension color 

 

This sets the color of the dimension lines and text. 

 

Dimension font height 

 

This sets the font height for dimensions. The size of the dimension arrows is adjusted 
accordingly. The exception is in the Publish task where the dimension text and arrows are 
shown onscreen as a scaled preview of the Picture output based on the chosen PPI. 

 

Note: The measurement unit used for dimensions is the same as specified for all the 
application in Settings > Measurement unit (see Measurement unit). 

Show Edges 
You can display geometric edges of various elements as visible lines onscreen and in published 
images. This is useful to help distinguish each product and bay element in your planograms.  

To show edges: 

1. Open the Display menu or the Context menu > Display. 

2. Click on Show edges (Keyboard shortcut E).  

 

The edges are now drawn for the following cases and objects: 

• For all room and bay elements (including the bay preview in Create Bay task) 

• For products which use the box shape and have no image applied. 

• For generic products (see Add Generic Products) 

• For all products, when Schematic View is ON (see Activate Schematic View) and 
Products style is set to Box & label in the user settings (see Product style). 
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Show edges in Schematic view with Box & label product style 
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Show edges in non-schematic view 

Show Flow Direction 
The flow directions defined for each bay in your project can be shown onscreen as arrows.  

1. Open the Display menu or the Context menu > Display. 

 

2. Select Show Flow Direction. 

3. The flow direction arrows are now displayed as shown below. 
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4. Repeat the same command to hide the flow direction arrows. 

 

Important Note: If no flow direction has been set for your bays, this command has no effect. 
See Bay Flow Direction for details on how to set the flow direction for your bays. 

Background 
This section shows you how to change the Background of your planograms. 

Background Color 
You can change the background color of the viewing area: 

1. click Settings on the upper toolbar. 

 

2. Click on the color swatch next to Background Color. 

 

3. Set the value by picking any color from the color popup dialog. (default color: white) 
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4. Click OK to confirm. 

 

Note: When you change the background color, the latest color is saved in your account and re-
used for new projects. 

Note: The current background color is also used when publishing Single Pictures.  

Note: The current background color is NOT used when publishing Report Pictures because 
reports have their own background color setting overriding the viewing area background. 

Background Picture 
You can also upload an image to use as the background for your planograms: 

1. click Settings on the upper toolbar. 

 

2. Under Settings affecting the current user only, below Background Picture, click 
Browse… 

 

3. Select a picture on your hard drive. 

4. Click on Open. 

 

To remove the background picture, click on the small red cross button.  

 

Note: The background picture is saved per user and applies to all projects. 

Note: The current background picture is also used when publishing Single Pictures.  

Note: The current background picture is NOT used when publishing Report Pictures. 
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Warning: If you delete the image from your computer, or if you open PlanogramBuilder from a 

different computer, the background image won’t be displayed. 

 

Tip: If you have taken a photograph of the 
store area where you project will be 
implemented, you can use a photo as the 
background and see your project in 
situation.Fullscreen 
The Fullscreen command switches the viewing area to full screen. In this mode, there are no 
more buttons, but you can use the right-click context menu or use keyboard shortcuts (See 

Keyboard Shortcuts). Press the Esc key to exit full screen. 

 

 

 

Tip: this command is also available in the Display menu or the Context menu > Display.
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On-screen Visual Quality 
You can set the viewing area visual quality to accommodate for the performance of your 
computer. 

1. Click on Settings  

 

2. Under Viewing & Editing, check or uncheck Antialias while moving. 

 

• When checked, the on-screen image is always antialiased (smoothed) even while 
navigating the view or Move Items in your planogram. 

• When unchecked, the 3D on-screen image is antialiased only when static. The image 
quality is a little harsher while moving objects or the view. Choose this setting if you 

experience slow response while moving the view or objects. 

 

Note: This setting has no effect on the quality of images that you output from 

PlanogramBuilder, such as in reports. These images are always antialiased. 

 

• Only the first sheet of your spreadsheet is taken into account for import. 

1. Download the following file and save it on your desktop: 

https://planogrambuilder.com/downloads/sample files/sample empty bay.xlsx. 

https://planogrambuilder.com/downloads/sample files/sample empty bay.xlsx
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Publish 
 

The Publish task lets you create images and reports of your planogram projects so you can 
communicate your guidelines to the persons in charge of setting-up the products in the stores. 

Single Pictures 

 

The Single Pictures feature lets you output images of what you see in the viewing area. Your 
current onscreen Display Modes and Options are maintained in your output pictures.  

This feature is useful to create simple and quick planogram images or images from custom 
viewpoints. 

Pictures can be placed in the Windows clipboard or saved to a variety of image file formats. 

Tip: If you want to publish reports with a product list and pictures, please see Reports. 

Single picture commands 

 

There are two ways to save pictures: 

Copy picture 

The Copy picture command on the bottom toolbar takes a snapshot of your project as it 
appears in the viewing area and saves it to the clipboard. You can then directly paste it in 
another application like Microsoft ® Word, PowerPoint, etc. 

 

Save picture 

Click the Save picture button to save an image of your project as it appears in the viewing 

area to your local hard disk. You will be requested to select a destination folder and a filename.  

 

Note: Use the File format drop-down list to define in which format the pictures are saved. 

Single picture parameters 
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There are several options to personalize your pictures. All the options below are saved by the 

application for the next time you use PlanogramBuilder. 

 

File Format 

Provides a choice of file formats to save the pictures. Available formats are: 

• JPG (Joint Photographic Experts Group): a good size-quality tradeoff for everyday use. 

• PNG (Portable Network Graphics): lossless compression, higher quality but bigger size 

than JPG. This is better suited for printing. 

• BMP (Bitmap): no compression, same quality but bigger size than PNG. 

• TIF (Tagged Image Format): lossless LZW compression, similar size to PNG, suitable 

for print. 

• GIF (Graphics Interchange Format): lossless compression, but only 256 colors 
maximum. 

Transparent Background 

Specifies the type of background to use for the pictures saved to disk with the Save picture 
command: 

• Unchecked: the picture uses the current background. 

• Checked: the picture background is transparent. This is convenient if you wish to 
overlay your planogram picture on your choice of background in another document. 

Note: This option is available only with the PNG and TIF file formats. 

Note: Pictures copied to the clipboard with the Copy picture command cannot have a 
transparent background. 

Default folder 

Optionally specifies where images will be saved by default: use the Browse button to select 
the folder on your PC. You can also type the folder path directly in the text box below. 

Orientation 

Lets you choose if the image should be in portrait (vertical) or landscape (horizontal) format. 

Picture size 

Provides a list of predefined values defining the dimensions of the images to save. This list 
includes common formats in pixels or in printed size.  
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If you don’t find a suitable preset value, you can choose Custom in the list and set your own 

width and height values in the box below. Enter values as follows: [width] × [height] [unit (cm 
/ mm / in / px)]. If no unit type is entered, it defaults to the current measurement unit set in 
Settings. 

 

You can specify any values up to 8000 × 6000 pixels (a monster 48 M pixels image) or even 
more if your system has enough memory. Typical use for very high resolution images includes 
booklets with prepress quality or big size posters that you can use on a tradeshow booth back 

wall. 

When you change the picture size and orientation, the viewing area is automatically resized to 
match the aspect ratio of your final picture. This comes handy to fine tune the aspect (using 

the Pan and Zoom tools) before taking a picture with a perfectly predictable result. 

Resolution 

Sets the number of pixels per inch (PPI) in the image. You can use presets or a custom value. 

• If you have set the image size in cm, in or mm, the PPI determines how many pixels 
will contain the image. Ex: a width of 10 in × 200 PPI = 2000 pixels in the image width. 

• If you have set your image size in px, the PPI determines the printed size. Ex: a width 
of 1500 px / 300PPI = 5 inches (12.7 cm) wide for the image. 

 

Note: Your picture parameters are saved for your next session. 

Note: If you have turned on Dimension Lines onscreen, your output pictures also include 

dimensions of bays as previewed in the Publish task viewing area. The size of the dimension 
text and arrows is adjusted automatically to result in a text height of 3mm in your printed 
picture, based on current Picture size and Resolution values. 

Reports 

 

You can publish detailed reports of your planograms. These reports typically include the list of 
products and optionally accessories in your current planogram project as well as predefined 

picture(s) of the planogram.  

Reports are well suited for printing and transmitting your planogramming guidelines for 
implementation.  
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Example of an HTML report opened in Microsoft ® Word 

 

Report command 

 

 

To generate a report: 

1. Click on the Report button 

2. Select a destination folder  

3. Type a filename to save the report file(s) 

 

There are several options to personalize your reports. All the options below are saved by the 
application for the next time you use PlanogramBuilder. 

Report parameters 
Several options can be set to personalize your reports. 
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File Output 

 

File Format 

provides a choice of file formats to save the reports. Reports can be saved in the following 

formats: 

• HTML (Hypertext Markup Language) file with separate image files in jpeg format 
(planogram pictures and item thumbnails). Choose this format to: 

o Publish the report and images “as is” directly on an Intranet or Internet web 
site. 

o Open in Microsoft ® Word for further editing and printing. Once opened in Word, 
you can also save as PDF, DOC or DOCX documents, which regroups the 

otherwise separate listing and images of the report in one single file. 

• XLS and XLXS (Microsoft ® Excel workbooks). Choose these formats to: 

o Open and edit the planogram product listing in a spreadsheet application. 

Note: When printing the report from Excel, if the list is too wide to fit within the 
selected page size, additional pages are generated for the extra columns. 

Note: Planogram pictures and item thumbnails are embedded in Excel files. 

Note: Un these formats, any group that is shown in collapsed state in the Project Item 

List is also collapsed in the Excel report list. It can be expanded if desired in Excel. 

• PDF (Portable Document Format). Choose this format to: 
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o Obtain the report and images in a format ready to print or send to others. 

Do not choose this format if you want to further edit the report layout or content. 

Note: In the PDF format, each bay (images & product listing) is grouped on one page 
when possible. If the listing columns are too wide for the selected page size, additional 

pages are generated for the extra columns. 

Note: Planogram pictures and item thumbnails are embedded in PDF files. 

Create a folder 

Check this checkbox if you wish to have a new file folder automatically created when you save 

a report. The folder will be created within the folder selected in the Save dialog box and will be 
named with the same name as the report name. 

Formatting 

 

The settings below propose various options to customize the layout of your reports. 

Page size: several standard paper sizes are provided in the drop-down list. You can also 

select “Custom” and type-in specific dimensions. 

Note: Dimensions are displayed using your preferred measurement unit as set in Measurement 
unit. 

Notes: 

• Page size for PDF format is well supported. 

• When you open an HTML report in a web browser, the page size doesn’t have any effect 
when just viewing the report. Page size is only used to determine page layout for 
printing the reports from web browsers or when opening in paper-based applications 

like Microsoft ® Word. 

• The page size for HTML and Excel formats are not recognized by all web browsers and 
applications, as shown in the table below: 

 Microsoft ® Word 
Microsoft ® 

Excel 
Microsoft ® 

Edge 
Google Chrome Mozilla Firefox 

Page size 
support 

Yes No Yes Yes No 

In case page size is not supported, you must set the page layout manually in your application 
when you want to print a report, from Excel for example. 

Left, Right, Top, Bottom margin: sets the respective page margin in reports. 

Font: lets you select the font (Arial, Verdana, etc.) and the point size of the text for product 
listings in reports. The smaller the font, the more columns you can fit on a page. 

Text Color: lets you specify the color of text for product listings in reports. 

Background color: sets the color of the page background for reports. 

Border color: lets you choose the color of borders for the tables containing product listings. 

Resolution: this parameter defines the resolution in pixels per inch for all images in a report. 
Several preset choices are available and you can also enter a custom value. The higher the 

setting, the more detailed your images will be when you zoom in or when you print them. The 
tradeoff of a higher resolution is a larger file size. 
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Report Pictures 

 

You can include images of your planogram project in your reports. These images are different 
from the ones published with single pictures: report pictures are taken from predefined 

viewpoints and are automatically cropped and zoomed to fit your planogram nicely in the 
report. 

The following checkboxes let you choose which pictures to include in your reports. 

Project 

This picture displays all the elements in your planogram using the current display mode 
(realistic or schematic). 

The project report picture appears just after the report title, before any other image and report 

list. 

 

       Project view - Front 

Bay(s) view 

A view of each individual bay is included in the report. 

Note: If you have grouped items by Bay name or Bay number, bay pictures appear in the 
report above their respective bay item list. In all other cases, bay images appear above the  
project item list. 
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           Bay view 

Bay(s) schematic view 

A schematic view of each bay with is included in the report. PlanogramBuilder uses the current 
values set in the settings for Schematic View to determine the schematic view style (Product 

style, Product label, etc.). 

Tip: To easily find each product in the report listing, set your schematic view to display 
Position labels on the products (see Schematic View Settings) and also include the Position 
column in the report listing (see Report List). 

Note: If you have grouped items by Bay name or Bay number, bay pictures appear in the 
report above their respective bay item list. In all other cases, bay images appear above the  
project item list. 
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       Bay schematic 

Notes on Report pictures: 

When you output report pictures, the visibility of the following elements depends on your 
current display modes (see Display Modes and Options): 

• Dimensions 

• Edges 

• Peg Hooks 

• Flow Direction 

• Room 

 

If dimensions are turned ON, the dimensions shown in the report pictures vary depending on 

the type of pictures: 

• Project pictures include the dimensions of each bay cluster (each isolated bay and 
each group of adjacent bays). Dimensions of room elements are also shown, but only 
for room elements which are selected in the viewing area. Bay pictures (Bay and Bay 

schematic pictures) include bay dimensions, plus vertical shelf measures and lateral 
distances between dividers. 

• Note: The size of the dimension text and arrows is adjusted automatically to result in a 
text height of 3mm in your printed report images, based on the report Page size and 
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Resolution values. This does not correspond to the onscreen dimension text size in the 

viewing area. 

Report List 

 

Reports also contain the list of all the products used in a project. 

The report list content and parameters reflect what is displayed in the Project Item List. 

Make sure to configure the Project Item List to obtain the desired layout and content in your 

reports. We advise saving preset list configurations for different needs.  

 

Notes on groups in report lists:  

• If your Project item list is not grouped by any property, the report contains a single list 

with all items. 

• If your Project item list is grouped by Bay name or Bay number, the report contains a 
separate list for each bay in the report. 

• If your Project item list is grouped by any other property (ex: category), the report 
contains a single list with all items. Additional rows of a different color are included for 
each group name. 
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                                                 Example of a report list 
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Tips and Tricks 
If you often work with PlanogramBuilder you will find some valuable tips in this section. For 
example, if you learn the keyboard shortcuts for the features you use the most, using the 
program will be more fun and you will be more productive. 

Mouse Tips 

Left button 

click on 

empty zone of 
viewing area 

Deselects selected item(s). 

Left button 

double-click 

Fully selects the content of an edit box. For example, to change the text for 

the title of the application (see Application Title), double-click in the edit box, 
then type immediately the new value. 

Right button 

click 

Opens a context menu. Such menus are available when the mouse cursor is 

on top of an edit box or inside the viewing area. 

Scroll wheel Zoom: When the mouse cursor is within the viewing area you can use your 
mouse wheel to zoom in and out (see Zoom). 

Cycle between tasks: When the mouse cursor is within the upper toolbar 
area, you can use the mouse wheel to cycle between tasks: 

Cursor zone where you can switch task with the mouse wheel. 

Middle 

mouse 

button drag 

When the mouse cursor is within the viewing area, you can use you can use 

this key and mouse combination to temporarily pan the view. 

Ctrl+Scroll 

wheel 

When the mouse cursor is within a log text area, you can use this key and 

mouse combination to zoom in and out. 
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Keyboard Shortcuts 

KEYS EFFECT 

A Applies the Default (View All) command. 

B Selects the Edit Bay tool. 

C Temporarily disables collision detection (see Move Items). 

D Toggle the display of Dimension Lines. 

E Toggle the display of edges (see Show Edges). 

I Selects the Edit Item tool (to work with for products and accessories). 

L Toggles the Locked Accessories value for the selected bay(s). 

N Launch the Add Generic Product command. 

P Selects the Pan tool. 

S 
Selects the Edit Bay Element Tool (to work with shelves and other bay 
elements). 

T Applies the Top view command. 

U Turns a product Upside Down (see Rotating Products). 

V Toggles the Schematic View mode.  

Z Selects the Zoom tool. 

Ctrl + drag 

Allows duplicating easily objects with the Edit tools (to copy, bays, bay 
elements, Products and Accessories). 

Press Ctrl before clicking on the object and it will be duplicated when you 

start moving it. 

Ctrl + C  Copies values from edit boxes. 

Ctrl + V Pastes values in edit boxes. 

Ctrl + Z 
Undo: reverses one or several operations (see Undoing your Changes). 

Also cancels changes in edit boxes. 

Ctrl + Y 
Redo: re-applies operations that were canceled by the Undo command (see 

Redoing your Changes). 

Delete 
Deletes the selected item(s) (see Delete Bays, Delete Bay Elements, Delete 
Items). 
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Enter 

General: Confirms changes in edit boxes. For example, after typing a shelf 

dimension, press Enter to apply the new value. 

Database Editor: Edits the selected row when not already in Edit Mode. 
Updates the current row if currently editing the row. Creates a new item 

when the focus is on any element on the Create line. 

Project list: Opens the selected project. 

Esc 
General: Exits the Full Screen mode. 

Database Editor: Cancels editing of the current row. 

Left arrow 

Products: rotates the selected product 90° to the left (see Rotating 
Products). 

Walk mode: turns left. 

Right arrow 

Products: Rotates the selected product 90° to the right (see Rotating 
Products).  

Walk mode: turns right. 

Up arrow 

Database Editor: Moves the focus to the row above the current one. 

Project, database and catalog lists: Selects the line above the currently 
selected line. 

Down arrow 

Database Editor: Moves the focus to the row below the current one. 

Project, database and catalog lists: Selects the line below the currently 
selected line. 

Space 

Increases the precision of the mouse for many tools, like Edit (see Move 
Items), Zoom (see Zoom), etc. Pressing the space bar temporarily “slows 
down” the mouse; this lets you achieve a better precision. 

Tab 
Various panels: move focus to the next GUI element. 

Catalog lists: move focus down in the classification levels. 

Shift+Tab 
Various panels: move focus to the previous GUI element. 

Catalog lists: move focus up in the classification levels. 

Shift + drag 

a product from 
the catalog 

Inverts the selected product(s) placement mode: this lets you place on a 
shelf a product defined as pegged in the database, or place on a peg a 
product defined as standard in the database.  

Shift + drag  
while moving 
product(s) on 
a bay  

Inverts the selected product(s) placement mode when moving a product 
(pegged or standard). 

See Move Items for details. 

Space + 

Minus (-) on 
numpad 

For the selected product(s) in a planogram, decrements the number of width 

facings. See Change Product Facing Count. 

Note: There is at least one product left. 
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Space + Plus 

(+) on 
numpad 

For the selected product(s) in a planogram, increments the number of width 

facings. See Change Product Facing Count. 

Shift + Minus 

(-) on 
numpad 

For the selected product(s) in a planogram, decrements the number of 

height facings. See Change Product Facing Count. 

Note: There is at least one product left. 

Shift + Plus 

(+) on 
numpad 

For the selected product(s) in a planogram, increments the number of height 

facings. See Change Product Facing Count. 
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Troubleshooting 
This section contains explanations and workarounds for bugs and known issues. 

Known Issues 

Slow loading 

Problem: It takes forever to open projects, to upload pictures or to Export Database. 

Explanation: You may have a slow Internet connection to our servers. 

Solution: You can test your connection speed to our server at 

https://planogrambuilder.zvisuel.com/downloads/speedtest/  

If the reported speed is lower than 5 Mbits/s, it is normal that PlanogramBuilder takes a long 
time to upload and download items. 

Tip: Try to avoid working with a slow connection if possible: for example, switch from Wifi to 
Ethernet connection whenever it is available. 

Products not displayed 

Problem: I cannot see any product in the database preview area. 

Problem: I cannot see any product on the shelves when I load a project or when I 

drag a product onto a shelf. 

Explanation: some non-standard Microsoft Windows Internet settings may prevent file 

loading in PlanogramBuilder. 

Solution: Reset Internet options: 

1. Close PlanogramBuilder 

2. Open Windows Control Panel. (not Windows Settings) 

3. Click Internet options. 

4. Click on Advanced tab. 

5. Click on Reset... 

6. Click OK to save the settings. 

7. Close Internet options. 

8. Restart PlanogramBuilder. 

9. Now your products should display in PlanogramBuilder. 

https://planogrambuilder.zvisuel.com/downloads/speedtest/
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Product pictures not displayed 

Problem: I've tried to upload an image of a product, but the preview shows a white 

object (or it still shows the old picture). 

Solution: Please do the following: 

In Database Editor, click on the line of the product in the list to refresh the 3D preview. 

Blurry text in the GUI 

Problem: The texts in PlanogramBuilder user interface are blurry. 

Explanation: Scaling on Windows display is not always well-supported. 

Solution 1: Set the PlanogramBuilder monitor to 100% scale: 

1. Close PlanogramBuilder. 

2. Open Windows Settings > Display. 

3. Click on the display where PlanogramBuilder was opened. 

4. Under Scale and layout > Change the size of text, apps and other items to 100%. 

5. Restart PlanogramBuilder. 

Solution 2: Set the PlanogramBuilder monitor as the primary display: 

1. Close PlanogramBuilder. 

2. Open Windows Settings > Display. 

3. Click on the display where PlanogramBuilder was opened. 

4. Under Multiple displays, check Make this my main display. 

5. Restart PlanogramBuilder. 

Solution 3: Fix scaling for apps in Windows: 

1. Close PlanogramBuilder. 

2. Open Windows Settings > Display. 

3. Under Scale and layout, Click Advanced scaling settings. 

4. Under Fix scaling for apps, turn on Let Windows try to fix apps so they are not blurry. 

5. Restart PlanogramBuilder. 

Solution 4: Restart the computer: 

1. Close PlanogramBuilder. 

2. Restart the computer. 

3. Restart PlanogramBuilder 

Notes:  

• On older Windows versions, display settings are accessed from Windows Control 

Panel. 

• You may have to apply several of the above solutions to fix the blurry text issue. 
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Assistance 
If you purchased through a reseller providing support, please contact him directly for 
assistance in your language. You can check in our reseller list if your reseller provides support 

service. 

If you purchased through zVisuel or if your reseller doesn't provide support, you can contact us 
directly in English or in French. 

Email 
mailto:planogrambuilder@zvisuel.com 

Email support is free and we usually reply to your messages within the next business day. 

Phone 
+41 (0)21 311-52-53 

Phone support is available at standard rates during Swiss office hours on weekdays (9h-12h, 

14h-18h, GMT+1). 

Remote session 
zVisuel can connect to your computer to assist you through a real time support session. Please 
first call or email us to if you think you need a remote assistance. Download the remote 

support client application only if you are asked to do so by our support team. 

 

https://planogrambuilder.com/resellers.html
mailto:planogrambuilder@zvisuel.com
https://planogrambuilder.com/downloads/remote-support/PlanogramBuilderSupport.exe
https://planogrambuilder.com/downloads/remote-support/PlanogramBuilderSupport.exe
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